Mission planner update problem


I just updated my Mission planner to the latest version on an elderly win XP laptop. version 34 of MP had been working fine until the update. 

After completing the update, when I try to open MP either from the shortcut or the program list I get a warning that this application is not a win32 bit application. 

I have tried to delete the entire program and reload,... not better. 

I tried to reload MP ver 34 this will not work either. so now I have nothing that works.

Any ideas guys. 

Thank you

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    please update to the latest beta MP.

    it will support windows xp again.

    • Moderator
      Thanks Michael. Great job
    • Thank you very much Michael!

    • Many thanks. I will try it this weekend.

      • Yahoo!!! XP works again with latest beta..

        Michael, Thank you wery much!

  • I second the motion! XP XP XP and the crowd goes wild.

    I also use it for cheap field laptops.

    • As I understand MP now is using .NET 4.5 which is not supported on win XP.

      That's may rise problems NOT only for Win XP users but also for Linux users

      running MP under Mono. As I know latest Mono is only PARTIALLY support .NET 4.5

      Not all capabilities of .NET 4.5 are implemented in Mono for now.

  • Developer

    MP 37+ no longer support xp.

    you can get the old msi here

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21