MissionPlanner crashed under Mac & Mono

Hi,

i Installed the latest Mono for MAC (OS X 10.8.4) from here:

http://www.go-mono.com/mono-downloads/download.html

and installed it on my mac

Then i copied the latest installation of the MissionPlanner from my PC-Laptop to My Mac

to the users "Applications" Folder, and tryed to run the exe  from console:

macbookpro:APM_PLANNER macuser$ mono ArdupilotMegaPlanner10.exe

Thats what i earned:

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.WindowsFormsSynchronizationContext ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeEngine ---> System.ArgumentException: The requested FontFamily could not be found [GDI+ status: FontFamilyNotFound]
at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0 
at System.Drawing.FontFamily..ctor (GenericFontFamilies genericFamily) [0x00000] in <filename unknown>:0 
at (wrapper remoting-invoke-with-check) System.Drawing.FontFamily:.ctor (System.Drawing.Text.GenericFontFamilies)
at System.Drawing.FontFamily.get_GenericSansSerif () [0x00000] in <filename unknown>:0 
at System.Drawing.Font.CreateFont (System.String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte charSet, Boolean isVertical) [0x00000] in <filename unknown>:0 
at System.Drawing.Font..ctor (System.String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont) [0x00000] in <filename unknown>:0 
at System.Drawing.Font..ctor (System.String familyName, Single emSize, System.String systemName) [0x00000] in <filename unknown>:0 
at (wrapper remoting-invoke-with-check) System.Drawing.Font:.ctor (string,single,string)
at System.Drawing.SystemFonts.get_DefaultFont () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.Theme..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.ThemeWin32Classic..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.ThemeVisualStyles..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.ThemeEngine..cctor () [0x00000] in <filename unknown>:0 
--- End of inner exception stack trace ---
at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.Control..ctor () [0x00000] in <filename unknown>:0 
at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:.ctor ()
at System.Windows.Forms.WindowsFormsSynchronizationContext..cctor () [0x00000] in <filename unknown>:0 
--- End of inner exception stack trace ---
at System.Windows.Forms.Control..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.ScrollableControl..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.ContainerControl..ctor () [0x00000] in <filename unknown>:0 
at System.Windows.Forms.Form..ctor () [0x00000] in <filename unknown>:0 
at ArdupilotMega.Splash..ctor () [0x00000] in <filename unknown>:0 
at (wrapper remoting-invoke-with-check) ArdupilotMega.Splash:.ctor ()
at ArdupilotMega.Program.Main () [0x00000] in <filename unknown>:0

Any ideas to get it run?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Installing XQuartz gets you a bit further and solves the font problem, but MP under Mono on OS X is painfully slow. I found it's better to run Windows 7 under VirtualBox and run MP there. You need a copy of Windows though.

  • Make sure you reset your file permissions after a copy 

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…