What little hair I have is puled out!! I'm working my way through setting up an apm 2.6 for the fist time and am stumped. I'm using Afro 30's and have calibrated the radio and the ESC's but when I arm the copter the motors spin slowly as they should but only accelerate very slowly and no where near full speed when I apply full throttle. The are very responsive in the calibration procedure so they can spin up to full throttle but they won't under flight conditions. Any help would be really appreciated. 

Views: 4394

Reply to This

Replies to This Discussion

Anyone have any ideas? I've tried everything I can think of. I've calibrated and recalibrated the transmitter and ESC's and still the APM arms as expected and the motors spin slowly. If I apply full throttle the motors slowly increase in speed but nowhere near full speed. I can hear the motors respond quickly to inputs from the ail/elev stick. Also for some reason I have to hold the throttle stick to the lower left to get the APM to arm. (this may just require the channel to be reversed) Is there a throttle gain setting that needs to be increased?

Found it!! The very last parameter in Advanced Parameters is "throttle maximum" and for some reason it was set as low as the slider would go. It works now... thanks for nothin'... LOL ... I hope this helps someone else!

Hello and thanks for the info...i did the correction in "throtle maximun", but nothing happends up to i did a new radio calibration. Now it works! thanks a lot!

I am having the same issue...hopefully you are about to help me as well!  :)

Awsome! I have been trying everything (except for this) . Thank you!

I've had nothing but problems with several APMs and now the last one was the same as yours. And when I looked at the "Throttle Max" parameter, it was set to 80. I increased it to 1000 as suggested in the menu, but the motors are still only spinning slow.

So....... more troubleshooting 

I also had the same problem.  Thanks for posting this, I would have never found the issue without the post.  My Throttle Max was also set to 80.  

Same here with an APM Mini, thanks..

Same problem here, Tricopter V3 + APM 2.6.

Will try this weekend!

I had the same issues. Once I set the "Throttle Max" parameter from 80 to 1000, I then had to recalibrate the ESC's to recognize the new throttle high/low values. After doing that, the motors would spin up with the throttle inputs. I realize your question is six months old, but it might help someone else. 

helped a lot thank you! but i couldn't find the parameter in the advanced tap, i found it in the full parameter list under the name "THR_MAX"

THANKS MATE for the solution ..i was stuck with this throttle stuff and it was getting on my nerves..keep helping ;)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service