Hi,

I have the problem mentioned in the title.

When arming, all the motors spin up to high rpm immediately with no response to the position of the throttle lever.

After setting the value (mot-spin-armed) to zero, the motors does not spin anymore when arming - as desired.

But when I raise the throttle (0.1%), just touching the throttle lever, all the motors starts and spin at

high rpm. There is response to the position of the throttle lever now. But no slow speed raising possible, the "iddle" or minimum speed ist WAY to high.

I use ESC from  Hobbywing. Platinum Pro, 40A (the blue ones).

The ESC are checked one by one with the program card for the same values and calibrated one by one with the throttle up- connect- throttle down- disconnect- procedure.

My ESC setting is:

1 brake = off

2 batt type = Lipo

3 cut off mode = soft

4 cut off threshold = low

5 start mode = normal

6 timing = 15 (is that medium?)

Running them one by one directly through the Rx channel 3 they start smooth and raise speed normal until the maximum.

I already set and reset, but nothing changes.

Any help to resolve this puzzle is greatly appreciated !!!!!!!!!!!! :)

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • Throttle Hold is a Heli function.

    Do you have your Tx set for Acro or Heli?

    • ok, I checked the throttle hold an it is alredy INHIBITED.

      The Tx setting is for wing / plane (acro).

      After another new setup from scratch, re-burn, new calibration and settings -  the problem persists with the following changes:

      Now the break point for the sudden jump to high idle is at 3% throttle. And the first time I turn the system on after the ESC calibration, the speed of the motors rise slowly by itself (hear it in the video).

      [If I would try to fly with this settings, the copter never land again because of the high idle or I have to shut down and crash.]

      Please take a look at the video (perhaps better than words?).You see the calibration routine.

      In the calibration mode  all runs smooth and fine! After exiting the calibration mode and going then in to flight mode, you hear the "jump" to higher speed @1:15 and the run away of the speed.

      The stick response is very delicate from 0% to 3%.

      I need to find a way to straighten the curve from 0% throttle to 3% throttle.  That is the only remaining issue.

      https://www.youtube.com/watch?v=oAX0oziH1_Q

      YouTube
      • 3702705231?profile=original

        SOLVED !

  • You don't need to unplug anything.

    Tx - on with throttle at max

    Connect battery to copter -  after initialisation beeps wait for program beep from ESC's

    Disconnect copter then reconnect with Tx throttle still at max.

    after initialisation beeps wait for program beep from ESC's

    reduce throttle to min

    wait for initialisation beeps from ESC's

    Done and Calibrated

    Be aware the motors a live at this time even though the APM is disarmed.

    At this point you can test linearity by gently raising the throttle .

    • Aha :) progress made:

      I learned that the calibration does NOT work with the USB cable connected to the PC.

      I also found, that the "motor test" in Mission Planner allows the motors to spin very low (@12%) through the APM.

      So I did as you wrote me up. THANK YOU  (a variation of what the Hobbywing ESC manual says) and I FINALLY got a very low rpm when slowly raising the throttle.  Cool!

      Ok so far. But how do I save the calibration? When I reconnected the copter, I'm again in the very high minimum throttle, the values were not saved.

      Repeating YOUR calibration method works fine every time, but I'm unable to save the settings, after unplugging (throttle down) and plugging in again (to go in to flight mode) nothing changed, again the high idle :(

      How do I save the calibration?

      Hope that we're close to resolve the puzzle ;)

      • Two possibilities:

        Their is something strange about saving ESC calibration or they calibrate themselves on power up (I believe that some Afro ESC's do this and so don't need calibrating)

        or

        I am wondering about the THR_MAX value and why it was set to 80. Have you changed many parameters?

        If you have been fiddling with other parameters, or if that was how it was, then it might be simpler to just reset all parameters to their defaults and go from there.

        In practise I have found the default parameters to be a very good place to start unless you have a very non standard frame.

        • Hi,

          sooooooooo .......... I did all new from scratch.

          Disconnected all the wires and reconnected them with double checking.

          In Mission Planner, I reset the whole thing and started from the beginning ........

          frame, acc., compass, radio cal., all complete.

          Then the cal. routine again: Tx power on, throttle to max., connect the Lipo and immediately after the two beeps throttle down to 0. Wait for one beep. Now raise the throttle slowly, all the motors start at the same time about 4.5% throttle, run very smooth in calibration mode, respond good to throttle changes.

          Then I disconnect the Lipo with throttle at 0 (minimum), reconnect the Lipo, when the throttle is slowly raised, the motors again starts at VERY high idle, the ESC did not retain the calibration,  though the manual say it should with the procedure described.

          To my really big disappointment, I'd no success, still the ESC don't hold the calibration.

          Don't know what to do now. After all, it would be a shame to let the copter sitting in the basement.

          I will open a new discussion for the ESC only, perhaps a ESC guru chime in?

          Can not find an E Mail or support address from HobbyWing. Anyone?

          Mike, I want to thank you very, very much for your time and all the tips and ideas you gave me to find the ESC problem and point me to a solution!  Big THANKS

          • If you just reburn your firmware it does not reset your parameters.

            What I find is necessary is to burn arduplane or ardurover then reburn arducopter.

            This will rewrite all parameters.

            Now that we no longer have the CLI to do this I found this the best way to do a full reset.

            • ok............. I'll do that.

              Another straw to grasp for a drowning newbie :D

              Makes sense, setup something different (=arduplane) and this way do a total reburn.

              Thanks for the idea :)

              • Update:

                I did as you recommended, a 'full reset' + new clean setup from scratch.

                { btw, after looking into the untouched 'reburn' I found that the THR_MAX=80 parameter is there - of course I set it to 1000.}

                Unfortunately no changes. Again a very high idle, I worry it would cause an unwanted hoover or flip when prop's on.

                Think I can not blame the ESC's because before leaving the throttle calibration mode the respond is very good. There is something not optimal in the settings that affects the start point of idle.

                I guess that the problem is hidden in the throttle (value) settings and their relation to each other. It is in the APM 2.5.Too bad I'm new to this.

                I have to learn: How can I move the idle start point closer to a low rpm idle and smooth the sudden step at 4.5% stick position ?

                (pls see graph attached)

                .throttle diag.JPG

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…