Motors turned off in midair

Hi everybody,


got some testing done on 2.0.49 this weekend. At first I tried loiter which worked ok. After that a little mission with three waypoints. It missed one but it worked ok so far. So there are some really good advances though the last versions. Thank you for that.

Last test was guided mode. First two attempts went perfect. It set its orientation to the goal location; moved to it and chanced to loiter mode. At the next "fly to point" I set the altitude to high. As soon as I realized it I wanted to abort by chancing to stabilize. This is when things started to go wrong. The mode switched to stabilize and I was able to control roll and pitch, however, I was not able to adjust throttle so it kept rising. Tried to switch to loiter and back to stabilize in the hope to get control of throttle again but instead all the sudden there was silence as all motors turned off. I was not able to get the motors to start again before it "landed".

I read somewhere in the forum that this happened to somebody before. Turned off motors in midair were linked to the usage of a telemetry downlink in that posting. I also do have a telemetry link but believe that it has something to do with switching modes as this is the second time this happened. Both times when aborting guided mode.

There is no logfile on APM even if I do "dump logs". I can only attache the Mission Planner log.

Could somebody of the developers have a look at this? Thanks.






2011-10-22 05-09-16.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you happen lower the throttle, then gun the motors suddenly when it was descending?


    IIRC, if you move the throttle very quickly over something like 20% of its range, the failsafe kicks in and kills the motors.


    This happened to me in the past in the same scenario.  The quad got way too high, I lowered the throttle too much, then I punched the throttle to compensate before it hit the ground and the failsafe kicked in.

  • Try "dump 0", then select all with Control-A, then paste that to notepad and it save as a .log file.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21