Motors Wont Arm

Hi Guys,

I have been trying for weeks to get the motors to arm with the Ardupilot 2.5+.

Have connected to mission planner and in setup/motors they each rotate in turn but with a much longer pause after the fourth motor, not sure if thats normal.

Have done the all-at once ESC calibration and the beeps seem correct. Holding down throttle and stick and over to the right for 15 seconds, the red led on the board keeps blinking and (believe it should go steady) and nothing happens, no motor operation. 

Have done the radio calibration many times.

Setup is JR XG7, RG831B receiver, Turnigy Plush 30A ESC's and Turnigy D2836/8 motors x 4.

Really would appreciate some help please.

Cheers John

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I finally worked out the fail to arm problem. Thought I would share it with you.
    First, in the heads up display in the the Mission Planer software it tells you what the fail to arm problem is. In my case it said a "magnetic problem". The bench I was doing all the testing on has a steel frame under the timber top. While calibrating the compass with the Ardupilot I was too close to the bench top, so the calibration was not complete. Simple when you know how!!!

    John
This reply was deleted.

Activity

DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
yesterday
DIY Robocars via Twitter
yesterday
Derrick Davies liked lisa TDrones's profile
yesterday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
More…