My compass is showing wrong header with about 30 degree

I have noticed this since i started with my APM2,5 board but focused on other stuff until now.

I have my declination values correct (2,155041) and my satcount is 9.

Also my quadcopter icon in MP is a + Quad and not a x Quad as i have defined. 

I enclosed a screenshot from MP. 
The direction of my header is like the black line, not the red line.

mp.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Icon being a PLUS is correct, even if you defined X

    In Mission Planner;

    Configuration Hardware Options Compass perform [Live Calibration]

    Configuration ArduCopter Level make sure X is selected and perform [Calibrate Now]

  • Have you tried the 'live calibration' using Mission Planner?   You may have to do it more than once, though, some times the calibration is worse. It must have something to do with the way I moved it around or ???

    APM is  supposed to 'tune' the calibration during flight, I think.

    Some time ago I had noticed a similar problem with my APM 1 (2560) & 'H' version IMU.  [about +130 degrees out of wack!] .. My plane suddenly wanted to fall out of the sky after reach half way through a mission. I gave it every chance to recover on it's own but once it got below 25 meters I had to go manual.

    A review of the logs showed the compass pointing backwards, the GPS, my gopro & two eye witnesses say otherwise.

    [now to be fair, that particular IMU had been submerged in two fresh water lakes and after careful drying & cleaning it work without any trouble for several months.]...but I digress...

    I put the IMU aside & assembled a spare fresh IMU board.

    on the bench, with a fresh IMU I compared it with my APM 1 (1280) & the IMU from my Quad , The (1280) was closer [+15 degrees] but not quite on the mark.

    I swapped IMU boards [ both H versions] & the APM (1280) was quite close without even calibration.

    So then I continued to attempted the live calibration routine, again, with both boards. I did this many many times and it got pretty close..but it was still off by about +5 to +10 degrees.

    Still not satisfied with the results, [ I mean this is a compass, like WTF.. even my inexpensive boy-scout type compass was exactly correct & so was my 3-year old cell phone which uses a magnetometer too]

    I tried different firmware versions too.

    Eventually I left them both running for six or more hours, resetting them once or twice at arbitrary times.

    They now read within a degree of each other and they both show north when the board points north.

    Hope this helps.

  • I have the same problem as you have.. I have no idea what's wrong with this??

    if it takes auto-flight.. where it flies??

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
3 hours ago
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
8 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
8 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…