Hi, I was testing waypoint flight with APM 2.52+Ublox 6H on my skyhunter. The airplane was flying normally, but after switched to auto mode (waypoint altitude initially set at 60 m), the airplane did flow the waypoint path but the altitude drop till about 30 m before switch back to manual mode.

Then we tried it again. This time the waypoint altitude was set at 120 m. Still, the airplane went down gradually to 30 or 40 m while following the waypoint path, after switched to auto mode.

I attached the log here.Can someone help to find out what's wrong?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    Hi Shouyeh,

    This sounds like a bug that was fixed in the 3.0.3 release.

    Cheers, Tridge

    • yes, it does, but he's using APM, and that bug was EKF related.

  • I had a problem like your but flying in FWBA (what is more strange). I have started a request here http://ardupilot.com/forum/viewtopic.php?f=98&t=7657&start=10 (logged as Osmunda)

    • Please let me know what's the problem when you find out.

  • post .log from APM.

    • sorry for being late. I was out for a few days. Here is the .log.

      2014-05-19 15-34-20 87.log

      • sorry, your log is missing FMT messages, so mission planner does not like it.

        • Now .log can be opened. My RA took the KMT message from .kmz file and place to .log with a text editor, and it worked. The barometer seems to be OK. As you can see, the altitude dropped every time when switched to auto mode.

          What went wrong?

          2014-05-19 15-34-20 87.log

          • Your pitch is limited to LIM_PITCH_MAX  15deg.

            this is what Auto does, and still is unable to maintain altitude - maybe even influenced by high throttle. (if thrust vector is bad)

            once you switch and throttle goes down, it seems easier to climb.

            I suspect bad geometry of the plane.

            before flying auto modes.  - try this in manual mode:

            Have normal cruise speed (no transmitter trim)- let go of the sticks  - it should fly stright, and have very little vertical speed.

            Now - hit max throttle, the plane may now climb, but not too much - it should be able to do so indefinitly, not stall or loop.

            I suspect your model is pitching down with increased throttle, and/or does not fly level or climb slowly at max throttle.

            • The skyhunter was flying straight and level before switched to auto. Yes there were some radio trim but not much. Actually it was 2nd waypoint flight, the first one went well with the previous version of MP, but only did 4 waypoints and it was not windy as last Friday. Then we updated the MP.

              Will try again tomorrow. Have the barometer covered, reinforced the tail. Will see.
This reply was deleted.