Hi all,

I have been struggling for sometimes with Tricopter which I will use soon for the expedition in the Borneo Forest. I somehow can't calibrate well my radio. I use Spektrum DX6i (mode 2) bind to Spektrum AR6100e Receiver. I followed everything (hopefully) written in the wiki, and seems like I have problem in wiring.

I use APM 2.6 from 3DR and I connect receiver to APM Iput pins, so rudder to rudder, elevator to elevator, aileron to aileron and throttle to throttle. Then I attach the output pins no 1,2,4 to ESCs and 7 to servo, as

I understand it. Everything seems to be ok, when I connect the Tri to Mission Planner (I use Arducopter 3.1.1). GPS works well. Acc calibration works well. However, when I tried to calibrate the radio, something strange happened.

I push the throttle and it's not only throttle bar that is moving but also pitch and roll bars.

1. Throttle bar goes up, pitch bar goes down and roll bar goes left.

2. Yaw works fine (at least in my opinion as it's only the yaw bar moves accordingly).

3. When I push right stick (pitch) up, then pitch bar goes down and roll bar goes right and the other way around when I pull the right stick down.

4. Roll stick seems to work fine (push right then bar goes right etc.) however the lower limit is in the middle (the value for my case is 1507).

I tried my best to learn from others and search for solution but I haven't been able successful. I suspect that something is wrong with throttle, pitch and roll channels, but can't really understand why. Please if you have any idea, or any information , it would be amazing if you can help me with this issue. I have made several copters (mostly quad) without any problem at all, this is my first tricopter made.

Thank you so much for your help.

warm regards,

Rai

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Done!

    Finally solved the problem. It's somehow about the input from Tx which has created some problem. I set a new model on DX6i and everything is solved. Thanks

    • Hi Raj I had the same problem on my quad using a 9xr pro. Mission planner radio calibration shows the throttle and yaw reversed although in failsafe it shows the correct channels. Recalibration does not work and neither re binding. Created a new model in the tx and everything went back to normal. Your method solves it but still we dont know what causes this. I power my rx from the bec of my 4in1 esc because I get no power from the vcc out on the apm side. So when I calibrate I have to use the battery sometimes with the usb connected.

  • Dear all,

    I think I start to get the idea what's the problem.

    It most probably be in the DX6i Tx as when I move the throttle sticks, the other values (pitch and roll) are affected.

    I am going to try to figure it out.

    Thank you

This reply was deleted.

Activity

Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…