Hi Everyone,

Have a 2.9.1 quadcopter which flies really well in stabilize mode but when I attempt to use Loiter or RTL, it takes off at maximum climb. It's easily recoverable by switching back in to stabilize mode again but don't know whats wrong. Also, when it takes off, the first few metres seems to read the altitude correctly (sonar maybe?) but as soon as it gains some height the altitude soon goes negative. The altitude seems to be correct, but negative values. I am new to RC in general but I am thinking the neg altitude issue may be related to the loiter/RTL problem?

I do have sonar fitted which I have tested in the CLI and it is working but I have tried with the sonar on and with it off and makes no difference to the behavior in loiter/RTL mode.



Views: 2583

Reply to This

Replies to This Discussion

Before you try loiter or RTL, you need to see if altitude hold works. All advanced flight modes use altitude hold as a base. With RTL, the copter should climb to 15 meters and return to launch point. You must have GPS lock for RTL to work. Leave sonar off, it is not needed for altitude hold.

Thanks Richard,

I have tried Alt-hold as well but same thing, takes off like Apollo 11 :-)  Do you any idea why my altitude in the flight planner is negative? Dumb question, but that isn't normal is it?



No I don't have it cushioned (face palm to self). I will give it a try on Friday when I'm back home and give it another go.

Thanks for your help Paul & Richard, appreciated :-)


I crashed in some snow today and the APM got wet. I dried it out and when I plugged into Mission Planner I noticed the altimeter was showing something like negative 2 million. I did the CLI test altitude and it was outputting normal numbers, +/- a few centimeters.  So I erased EEPROM, reloaded 2.9.1, and re-input my config settings and viola!  Fixed. Maybe a drop of water got on my baro and I needed to reset things after that egregiously bad data? Not sure


I have had the same problem with one of my APM. after contacting Diydrone I was told the noise was within the specs and they offered to give me 50% discount with restriction attached for a new board. So I did not reply to their offer. I can post the exchanged email if you whish Pierre

Hi Guys,

Tried putting the APM on to a foam pad, also loosen'd the wires going to it. Checked that the foam block is inside the APM (yes it is). Result is I took it out today and it performed absolutely the way it should. Alt hold, loiter and RTL performed really well except vert landing speed in RTL is a bit slow...

Thanks HEAPS for your help everyone!!


did anyone ever answer about the negative altitude because i myself have the same problem and would like to know.  Mine also shoots off like a rocket but i also have mine covered.  Will find out after i run the baro test..

Hi Les,
Can you share the picture of your foamed APM?


@ Paul Hansel. I did this test. In my case, I had to type "altitude" after the "test" command. "airpressure" is not recognized as a command...

I didn't see any negative value. So hopefully my baro sensor is functioning okay. I haven't tested the "alt-hold" yet.

once i swapped out the material that was covering my baro sensor the altitude hold worked perfect .

Here's 2 pics of the APM mounted on the foam. I actually used concrete expansion joint for the foam ;-)

I am having a hard time to understand what a foam pad has to do with altitude hold function.

Foam pad will eliminate any unwanted vibration; that's understandable but how does it help with the altitude hold?

Does the barometric sensor vibration sensitive?

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service