New APM2.5 suddenly quit - no function or Mavlink - Need troubleshooting help

My APM2.5 just quit working while I was doing the final setup on my plane. It will no longer connect via Mavlink or 3DR telemetry to MP. At the time, I was mixing rudder control on my DX7-s to operate the FPV camera PAN servo with the GEAR switch. Everything seemed to work great, then the APM went completely dead. The rudder travel was set at 150% for the long rotation servo.
I had 3DR telemetry, FPV w/ MinimOSD, operating perfectly, Spektrum radio was calibrated and had 3 modes: MAN, STAB, RTL programmed. Aircraft surfaces responded to STAB correctly, then suddenly, nothing.

I disconnected everything including the GPS, and connected via USB to the MP. Connection fails at "Got param GND_ABS_PRESS" (62 of 183). I got access via Terminal and reset the EEPROM: no difference. I have since tried loading other older versions of Arduplane, but there is no accel, mag or GPS response.
Below is the schematic of my flight system. I can not see any reason for the failure due to my design. Please look it over and see if it is all correct. Also, I video recorded the functionality of the system prior to failure so that I could feature it on my website. I can post that video as well. Everything was working perfectly before the sudden failure. 
Any help appreciated. I just went from "Ready For Maiden" to "Totally Discouraged".

Views: 971


Reply to This

Replies to This Discussion

Sounds like your pan servo drew more than 0.5A and blew the fuse on the APM.

Looks like you are right. I would have exceeded 0.5A with the other 3 servos anyway. I didn't have power supply to the Output Rail. My mistake. I guess I was confused by the new supplied APM Power Module (rated 2.25A) and the absence of the JP1 jumper.

I tested and found continuity across the fuse near JP1, which I hope is not a bad sign.

Well, I didn't have a second power supply to the Output Rail. My mistake. I guess I was confused by the new supplied APM Power Module (rated 2.25A) and the absence of the JP1 jumper.

I tested and found continuity across the fuse near JP1, which I hope is not a bad sign.

Below is my revised Electrical Schematic. I believe I have it right now. May have costed myself an APM in the process tho.

If you took the 5v output from the step down reg and used that to power the PAN servo directly you might have some better luck, I.e. don't power the pan servo from the APM via the RX. The APM can provide power for the RX but I think it's a bad idea to try to power servos from the input side of the APM or from the analog output pins, e.g. The gimbal output pins. The other three servos will be fine as they're powered from the output side of the APM as long as your ESC can provide enough current for them.

Seeing as the fuse is intact, I am not sure why your APM is dead. Worth investigating that a bit further before binning it :-)

When I mention the output rail and input rail, I am assuming that the input rail is what the RX is connected to and the output rail is what the flight surface servos are connected to.

Here is a revised schematic with the mod you mentioned and the rails corrected. The Pan servo is a Henge MD260 with 600mA draw. I did not exceed the max by much, but that may have been the culprit.

I am not sure what to try next on the board. There is no apparent damage to it, but I can not get into "Logs" on the Terminal to erase them, and nothing else seems to make a difference. Resetting EEPROM, loading Arducopter or other versions of the firmware result in the Mavlink not being able to complete the connection.

If you can get to the terminal screen to do the reset and you can update the firmware and it all responds, then maybe you don't have too much if any damage to the board.

I found that the APM can be very picky about being connected via a USB hub. Sometimes it works and sometimes it doesn't. I ended up connecting directly to the back of the desktop machine when at home. What currently works and what does not work exactly? Is it just getting a connection to the mission planner (other than the terminal screen)? Does terminal work?

Yes, Terminal works.

The first line I get is always: 3No dataflash inserted 3COMPASS INIT ERROR

I can get response in all the terminal commands (setup, test, reboot, help) except logs. When I type 'logs' there is no response. 

I can upload 'some' versions of Ardupilot and Arducopter firmware via Mavlink, but none of them work. Most versions fail partway through upload. I have Arduplane 2.70 on it now. The AHRS never gets past "INITIALISING" in any firmware.

I am connected to usb on back of computer. I've also tried a different computer.

Looks like you have a broken board then going by the missing dataflash and compass errors. Perhaps someone more familiar with how the hardware is connected up may be able to know of any possible fixes, but without dataflash being detected it's not surprising that the logs command fails :-(.

Thanks for the input Kieran. I will have to find out who is doing APM2.5 inspection and repair. In the mean time, looks like I will be ordering a new board :-(

If it were easy and free everyone would be doing it and the adventure would be over.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service