New Pixhawk with DJI F450 kit- Motors Beeping

ok, so I currently have setup

The Pixhawk FC

A 5V BEC

4 DJI 30 AMP ESC OPTO

4 DJI 920 Motors

TBS Discovery Plates

Spektrum DX7 for remote

Spectrum Satellite receiver plugged directly into the FC

Everything was going fun until I tried to hook the ESCs and Motors to the FC.

Now when I connect the batter to the Power Module that came with the FC the FC comes up fine but the Motors start making a beeping sound and vibrate a little, like they are trying to spin.  If I unplug all the motors then no sound is present.  But when I plug them back in it starts up again.  

I have read things about the low throttle but I got that set below 1000 and still not working, any other suggestions? 

Also with this setup do I need the BEC or can i lose it?

EDIT:   Things I have tried 

NOTE:  When I say ESC is beeping, When I unplug the motors from the ESCs and plug everything in nothing beeps, but when I plug the motors back in, even just one, they beep.  Not sure if this is normal.

1.  Remove the Power Module that came with the FC and just supply straight power to the Frame (PDB build it) which powers the ESC to Motor Directly.  Motors beep about every second and vibrate a little. 

2.  Plug Power Module in without FC behing plugged in then plug in battery.  Motors still beep every second and vibrate a little.

3.  Plug in battery to Power Module but not to frame let FC power up then plug in frame.  Motors still beep every second and vibrate a little.

4. Plug Power Module in to battery while connected to frame.  let flight controller boot up, motors still beeping and vibrating a little.  Then I press and hold the saftly switch to solid red.  Motors start beeping very fast.  

I have read from here that the beep every second could mean Input signal abnormal and the steady beep could mean Throttle Stick is not at bottom.    

I am at a lose I have been on the internet all night and found things and tried them but no luck...and now on top of that when I go to callibrate my remote the Throttle stick isnt picking up it is putting the pitch switch for both pitch and throttle and I change the channel in the settings but it just changes back.  This was working before but then I rebound the remote and not its not.  

any help would be awesome guys, this is my first build. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hey Cody, I'm not using a TBS Discovery but a PDB no less.  In your setup in not using a BEC did you remove all but one of the four ESC positive and negative wires from the ESCs?  I'm not understanding why a BEC would be necessary in this style setup when no additional power is needed from the rails.  I do notice though that one ESC always gets warmer than the other 4, still trying to rule out a bad motor prior to losing the entire copter.

    • Hey e left, what I found is that you are correct if you do not plan to provide power to the back railed then you do not need the BEC. I already had mine so I still use it as a backup power to the flight controler incase something happens. I did not remove any ends from my escs and also have not know them to get warm. You could try checking the voltage to and from it with a volt meter.
      • Appreciate the response!

  • I'm having this beep ... beep ... issue and it won't silence or change to another pattern even when I press the safety switch and arm it.

    The beep pattern is exactly the same if not connected to FC.   The DJI ESC/Motors works fine if I connected them directly to the RX.   It seems no matter what I do, I can't get a signal out of this pixhawk.

    • The reason that mind did this was because the signal from the throttle on the TX was above 1000 once I adjusted it to below 1000 I was able to arm the quad.  I believe I have documented this on the post or another.  If you have trouble adjusting the mid on your TX let me know and I will see if Ican help more.  On the mission planner software when setting up your TX you can see what level your throttles lowest point is at.  Let me know if this helps.  

      • I read your posting a hundred times already and been searching the net for several nights :(

        I have similar setup to yours but with a F450 ARF.   I'm also using Spektrum satellite and had changed the transmitter travel adj. so that I could have a throttle value of 998.

        Initially, I thought it might be because I need a BEC for this DJI 30A OPTO so I've installed one and connected it to on one of the main PWM port.

        Another thing I did was downgraded the FC firmware to 3.1 and 3.11 to match what you had previously.    On your youtube video, I had exactly the same beep but in my case, after I engage the safety switch, the only thing that changed was the red solid light, the beeping pattern still remained unchanged.

        If I connect the ESC to the aux, then I would get the beep.beep sound just like the throttle is not in the low value.  Of course, I can't use that but it just shows that the ESC's works and reacts to some signals coming out of AUX out.

        There must be something that I've missed.

        • Try going lower on the throttle I think mine was a good bit under.  In my research I had found that the beep that it does means no signal to ESC.  This is because the flight controller cuts off signal during the arming phase until two things happen.  The throttle is low enough and the safety switch is pressed and help to arm.  Then I will release the signal to the escs.  I'm not how right now but if you need I can tell you what my throttle is set to once I get home.  

          • I could only go as low as 998.   I'm still using a DX6i transmitter and travel adj could go only until 125%, even with sub-trims adjusted, the lowest I could see on Mission Planner is 998.

            Even without adjusting anything, I could still arm the FC but it seems no signal is coming out to change the tone of these ESCs.

  • Hello Sam

    I am new to to quadcopters myself I was having so much trouble with getting my first build to work. I believe I was having similar issues to yourself where the motors/ESCs beep like mad when the safety is taken off the Pixhawk.I think I have a similar setup to yourself.

    After trawling through the mass amounts of forums online Cody's solution was the only one that worked for me and I can now confirm that my Quad flys, so thanks Cody you are a legend.

    Sam if you need any advice on how I got mine working, I'd be happy to help.

    Regards

    Garry

  • I have the same Problem with a F550 ARF kit.

    With a oscilloscope and a servo tester i have found that the minimum pulse-length of the pwm signal is to long. The ESC initializes at 1.07ms. The minimum-value from pixhawk is 1.17ms. The THR_MIN value is already 0 and negative values has strange effects.

    It seems to be a bug/incompatibility in the firmware.

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…