Newbi Needs Help

I not sure this is the best forum for this post. I f there is a better place let me know.

Thanks all in advance for helping me get my drone working!!!

 

I am a Newbie building my first quad and first time playing in the RC world. My problem is I can’t get any response on Betaflight between the flight controller and transmitter. I have followed instructions on numerous videos but no luck.

I downloaded Betaflight 10.6.0 and all the recommended drivers.

I purchased a Flysky FS-i6 transmitter and Flysky FS-iA6B receiver. I was able to bind the two together. I followed several videos on setting up the transmitter.

I purchase a Racestar Star F4S FLC. I have wired in the receiver, video transmitter and motors. All the solder joints appear good. I used the plastic screws provided with the FC.for mounting.

  1. I hooked up the FC to Betaflight and verified in “Setup” as I moved the drone around the drone picture on Betaflight moved with it.
  2. I then flashed the latest version of software to the FC.
  3. On the receiver I have tried both PPM CH1 and the IBUS with no luck. I did change the “Configuration Receiver” settings for PPM or IBUS when I changed to those receiver settings.The battery was plugged in during these attempts.
  4. In the Betaflight “Ports” setting I only have USB VCP Configurator/MSP turned on. I tried turning ON and OFF all the setting in the Ports page with no luck.
  5. In the “Receiver” page I set the Channel map the AETR1234.
  6. After all that I cannot get a response for Roll, Pitch, Yaw and Throttle when I move the controls on the transmitter.

I am completely baffled so any advice would be very much appreciated.

Eastbayboy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • @JC,

    In BetaFlight's "Configuration->Receiver",

    Select "Serial-based receiver (SPEKSAT,SBUS,SUMD)  <-there is no IBUS, but this is the item to select for serial protocols

    then select "IBUS" for Serial Receiver Provider"

    Click on "Save and Reboot"

    In "Ports", on whatever UART you have the receiver connected to, enable Serial RX slider (turns grey to orange)

    Click on "Save and Reboot"

    From the receiver, be sure you are using the IBUS Servo pins and NOT the IBUS SENS pins.

    You should have verified the wired connections are correct!

    Go to "Receiver" and you should see the colored bars move when you twiddle the transmitter sticks and switches. If you do not, then you either: made a Betaflight config mistake, your receiver is bad, your transmitter is bad, your wires are connected/solder wrong, your controller is bad, you're an idiot ( HA HA JUST KIDDING!)

    Oh by the way, I am using v4.2.0, but the menu items are similar in older versions.

    Good luck and I hope this helps...! 

    Tom

    P.S.Uh oh! Here come the quarantine police! Social distancing! Wash those hands with SOAP! Live a longer life!

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Sunday
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…