Hi all,

I cannot see any green bars to calibrate radio signals (AC quad, new APM2 board, Mission Planner, win xp)

do you have any hints for me to debug or solve?

board has gps lock.

My thought is that the Mavlink comms is faulty one way (sending to APM direction?/bad cable)

 

New APM2 recvd. full board with new gps and fully soldered.

I loaded firmware for quad and APM2 easily with Oborne's Mission Planner.

then went to first step - set up of board and no green bars at all in display.

Radio says bound.

In terminal tab of MP, I get the radio values to vary with stick movement (though some appear to be large negative values at times). This is only occasionally - sometimes I cannot get into test mode.

(is there an order that things need to be done and connected?)

Terminal mode gives the 'weird' characters sometimes.

 

Any ideas would be most appreciated.

 

Other:

cannot see any CTS setting for comm port

would try another cable but cannot as connector is special

would try another PC but it develops another issue (Mission planner does not start)

I have been successful with APM 1

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • SOLVED!!!

    can you believe it?

    after 8 long weeks and many attempts at solving I HAVE FLOWN.

     

    Solution - was to reverse the throttle on thTurnigy TGY 9x tx transmitter, not reverse in Mission Planner

    (I hate reversing throttle in any place - so probably not surprising I delayed fiddling with throttle)

     

    wow its so good to fly some.

    Brett

  • @John

    probs when connected to usb. I now have limited and sporadic success with calibration, though convoluted procedure of rx cable pulling and reinserting.

    @ Randy and R_Lefebvre

    A Turnigy 9x tx and two turnigy 9 rx's tried - about 2 yrs and 1 yr old respectively.

    @R_Lefebvre

    Aren't most of the new 'advanced' tx -rx combos going down this path to reduce servo delay in big models? If so APM2 software may need to go this path too - a suggestion only.

    Framerate: probably above my skills and patience with Turnigy tx's stiff buttons and lack of tx manual I'm afraid. But I shall take a look. One reader with Turnigy and APM2 has not had trouble. One with Futaba has similar prob. David D has similar prob with an AR8000 rx (tx unknown).

    It seems, from others, that lower end or fewer channel rx's help or solve the problem.

     

    all thoughts greatly appreciated as I know you guys are flying and I'm not :-(

     

  •  I can now proceed thru setup by taking 4 of 6 rx cables out before initiating radio calibration and inserting them back live to get all channels calibrated. weird hey.

    response from another thread of mine suggest it is more of a firmware issue of not being able to read receivers which buffer the outputs and output all channel values at once.

    This might be worth the developers or engineers looking into.

  • There is no radio in the APM2.  You have to add a serial telemetry radio.  Obviously you will not get radio signal readings with no radio.

  • still a problem, can you help please?

    The main problem is I cannot proceed past the loading of the AC2 software. ie. setup the radio settings nor enter CLI mode
     
    I have done the following to try to resolve myself:
     
    • reloaded the software using mission planner (several times and hence several versions of each)
    • used two other pcs (one Win 7 others XP)
    • tried another usb cable
    • took out dataflash card, restart, reinserted dataflash card (BTW "no dataflash" message seen but no reformatting message)
    • reset the board (many times at various stages of startup)
    • reloaded AC2 software using arduino ver 22
    after each of these things I check to see if I can get radio setup bars (waiting 60 sec) then go terminal tab and try to get cli , then go back to firmware tab and try to connect alone to mavlink. All of these without success.
     
    none of this worked and I have not had a working APM2 at all. At the very start I was able to get into cli and see the prompt but this only occurred once and very early on. I have never been able to see the green bars in the Mission Planner for radio setup. I have never seen the mavlink work.
This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…