No dataflash log

Started with arducopter recently and am facinated by it - everything went well and first flights are undertaken without problems - thanks to the team.

Now I want to take and read dataflash logs but have no sucess: After many flights I only get this log status:

3691060656?profile=originalWhy is the log Number so high = 55806?

Why is the start (4095) bigger than the end (4094) - After erasing all logs I did only a 2 minutes flight...

Thanks for any hints and helps

Rainer from Germany

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Rainer,

    Be careful with the Chip Erase function. I found this on the datasheet:

    29.1 Chip Erase
    29.1.1 Issue
    In a certain percentage of units, the Chip Erase feature may not function correctly and may
    adversely affect device operation. Therefore, it is recommended that the Chip Erase commands
    (opcodes C7H, 94H, 80H, and 9AH) not be used.
    29.1.2 Workaround
    Use Block Erase (opcode 50H) as an alternative. The Block Erase function is not affected by the
    Chip Erase issue.
    29.1.3 Resolution
    The Chip Erase feature may be fixed with a new revision of the device. Please contact Atmel for
    the estimated availability of devices with the fix.

    So I don't know if I have the malfunctioning revision.

    Anyway, one of my coworkers offered me his help (I have to say very generous person, highly skilled in C, he programs all our products :). He proposed me to write a C program which handles directly the Dataflash chip and erase it by using Block Erase as said in the datasheet.

    Let's see what happens then.

  • You might try the "Clear Logs" command in that Terminal window.  It seems to erase the whole log area all the time, and takes about a minute.

    If things are really messed up, maybe Save All Parameters to a file, then in terminal setup/reset (wipe all parameters), and Load the file, Write the parameters and start again.  I don't know if Setup/Reset wipes the log records or not, but it's worth a shot, similar to your arduino erase.  I don't think the eeprom on the Arduino is where the Log files are kept, though.. it's probably an external dataflash, which is why you have to use the Erase command in the Log controls.

    I wouldn't worry about the log numbers.. the dataflash pages might be used in circular or other non-obvious fashion.   You should have one Log for every time you connected the battery, and your logs look correctly enabled.  (Default bitmask).

    Logs are vital, so keep at it until it unsticks.  On mine, they take a long time to download over USB at 115200bps.  I do wish there was a way to download them over serial telemetry, but haven't found one.  Still, worth the hassle.

  • I found some reset procedure in the Mission Planner Terminal with "setup" and "reset" something happened - but still the same high log number and no recording - please help!



  • Hello to All,

    no clue about my problem?

    I uploaded the 3.0.1 firmware again but still the same status with the logs. How to erase the eeprom to get rid of all the old/wrong data - please help!

    Rainer from Germany

This reply was deleted.