No Flight Data On Iris+ RC Controller

I just received the new iris+ and am currently able to fly it with the RC controller but when I hold down the "DN" button on the controller I do not see any flight data, i.e. altitude, speed, battery, etc. when the iris+ is flying. I have gone through the initial setup on mission planner and am able to successfully calibrate the RC controller through the wizard tool.

Does anyone know how I can resolve this issue?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had the same trouble after upgrading to 3.3.2. It can be fixed by loading the default Iris+ parameters and writing them to the vehicle. The problem seems to come from the wrong serial 2 protocol settings that get changed from FrSky to others during the update. When you adopt the default Iris+ parameters you can then set them all back to what works with your factory Iris+ gear.

  • I just had the same experience, no flight data on new IRIS+.

    The 3DR website has topic on this in the trouble shooting section that suggest there are 3 different cables plugs that need to be checked (removed and reinstalled) to assure they are making good connections. 

    Troubleshooting controller-rc-data

  • I am now getting the same issue. I updated to 3.3 today and did all the calibrations. I am getting all the telemetry except for battery voltage and mah. Any ideas on how to fix this?

  • I just bought my 3dr iris plus last week and ready to fly it. I did the firmware update and calibration . I noticed that in my controller doesn't show the battery status. I bought four batteries all are 3dr batteries 5100mah i tried all four are fully charge and still doesn't shows on screen (sorry for my English i hope this make sense).

    Please help, i dont want to return or exchange to the store just yet, maybe im doing something wrong.

    the drone flew, and all information such number of satellite, latitude, distance, speed, time shows on the osd of the controller except the battery and mAh. any recommendation? I am very new flying drone.

    iris+ 3dr firmware update ac3.2.JPG

    • hello, I'm in the same situation as you. I hope you were able to repair or correct this in the rc. I hope you can help me, I can see the battery voltage tower in the application on android phone but not in the rc.
       
      Waiting for your answer

      regards

      • 3D Robotics

        Sounds like an incompatibility in the latest APM:Copter code. That's created by the community, not 3DR, so it's not a customer support issue. If you need the battery status, please revert to the factory code as shipped. 

  • When you go through the initial setup it wipes the custom firmware (3.2-iris) and uploads 3.1 which doesn't have the second telemetry setup from the pixhawk. You can contact 3dr and request the original firmware but the latest 3.2 beta build will work too. I'm using the latest beta build on an iris+ and it's perfect. I belive this will be out of beta in a week or 2 and will be the default firmware so I'd go with that.
    • In misson planner, under initial setup, there is a firmware page, in there is an option to use beta builds, this will download 3.2rc12 and upload it to the iris for you.
    • Thanks for your response. Do you have a link to the latest 3.2 beta build for the firmware?

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…