No GPS Fix?

Well this seems odd to me and no idea what to do.

I have 3DR Quad about a year old - I haven't been able to do anything with it for awhile and just getting back to it now.  APM 2.6.  I have a new receiver and Taranis FRSKY radio so getting everything hooked up.

I know gps was working in March because I did work on the copter for a bit and tested it then but didn't get any further.

There is power to GPS (Solid Red Light) but no lock showing on GPS.  I am getting flashing blue light so looks like GPS is powered up properly.  I tried loading the latest firmware 3.5.1 but that has not helped.

Not sure where to go from here so any idea would be quite welcome.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • before you replace the gps - check your gps wires for continuity, check the antenna connection- ive had wires break and the gps antenna connection come loose

    • Ok thanks for the tip - I'll give that a go.


  • How long did you wait for the lock?   Did you move inbetween?   It may take up to 30 minutes if it needs to download the ephemeris / almanac info. If it's longer than 30 minutes you're probably not getting a good gps signal (faulty antenna?). You should also check after power-off if it takes the same amount of time or only about a minute or so. Most GPS's save the info into EEPROM so it boots up faster next time. Hot-starts even have a battery to enable start-ups under a second.

    • Thanks for the reply- this is taoglas model.  I believe it has an internal antenna.  I never had a problem getting a fairly quick lock before.   But I am in quite a bit different part of the country now.  I feel pretty sure it was longer than 30 minutes but I may have moved or restarted in between.  I've been out for part of the day so going to give it another go now.



      • Also in Mission Planner it shows Sats as 0 - so I don't think it is downloading anything.

        • Sounds like it's got a problem when it stays that way. Usually you get a 2D fix within a couple of minutes at least. Just final confirmation as it wasn't stated: you test outside, right?

          • I did test outside.  so the only option you think is to replace the gps module?


            • If you're not getting any satellite ever outside, it sounds broken to me. unless someone else has another idea on this forum...

  • Oh - also tried powering up from both USB and Battery - same results

This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
Benewake LiDAR liked Benewake LiDAR's profile
Apr 12
Gremsy liked Gremsy's profile
Mar 12