No GPS Fix?

Well this seems odd to me and no idea what to do.

I have 3DR Quad about a year old - I haven't been able to do anything with it for awhile and just getting back to it now.  APM 2.6.  I have a new receiver and Taranis FRSKY radio so getting everything hooked up.

I know gps was working in March because I did work on the copter for a bit and tested it then but didn't get any further.

There is power to GPS (Solid Red Light) but no lock showing on GPS.  I am getting flashing blue light so looks like GPS is powered up properly.  I tried loading the latest firmware 3.5.1 but that has not helped.

Not sure where to go from here so any idea would be quite welcome.

Thanks,

Fred

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • before you replace the gps - check your gps wires for continuity, check the antenna connection- ive had wires break and the gps antenna connection come loose

    • Ok thanks for the tip - I'll give that a go.

      Fred

  • How long did you wait for the lock?   Did you move inbetween?   It may take up to 30 minutes if it needs to download the ephemeris / almanac info. If it's longer than 30 minutes you're probably not getting a good gps signal (faulty antenna?). You should also check after power-off if it takes the same amount of time or only about a minute or so. Most GPS's save the info into EEPROM so it boots up faster next time. Hot-starts even have a battery to enable start-ups under a second.

    • Thanks for the reply- this is taoglas model.  I believe it has an internal antenna.  I never had a problem getting a fairly quick lock before.   But I am in quite a bit different part of the country now.  I feel pretty sure it was longer than 30 minutes but I may have moved or restarted in between.  I've been out for part of the day so going to give it another go now.

      Thanks,

      Fred

      • Also in Mission Planner it shows Sats as 0 - so I don't think it is downloading anything.

        • Sounds like it's got a problem when it stays that way. Usually you get a 2D fix within a couple of minutes at least. Just final confirmation as it wasn't stated: you test outside, right?

          • I did test outside.  so the only option you think is to replace the gps module?

            Thanks

            • If you're not getting any satellite ever outside, it sounds broken to me. unless someone else has another idea on this forum...

  • Oh - also tried powering up from both USB and Battery - same results

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…