No HeatBeats from Mavlink -- The Saga Continues now w/ PixHawk

Thought the problem was a potentially faulty APM 2.6 so unwrapped my PixHawk.  Same problem.

In MP, it connects and downloads the firmware.  Pixhawk then gives the successful happy song.  Select connect via Mavlink:

- starts 30 second countdown

- red connect changes to green disconnect

- timer goes to 0

- continues trying or doing something for another 1 1/2  minutes while countdown stays at 0

- then get No Heatbeat error.

In Windows 8, Device Manager, Com 5 is set to 115200, 8 bits, no parity, 1 stop bit, no flow control, FIFO buffers.

In MP, Com 5 PX4 FMU v1.6 (COM5) is selected.

Tried:

- restarting the computer

- connecting via a different computer (windows 7 and an older version of MP)

- four different USB cables plugging into different USB connections (getting desperate)

- different com settings

I'm beginning to think i'm in a no heatbeat black hole.  will see if i can setup the radio (but can i do that without mp?)

Views: 15631

Reply to This

Replies to This Discussion

Tried the 3DR radio.  Same No Heatbeat.  Agggggg! :-{

So with the radio going, the PixHawk-Compter USB was disconnected so the Pixhawk was battery powered via the Power Module, so I can't conclude that this is a power problem.

The GPS is only flashing red, but this is expected, I think because I can't configure the hardware (step after the firmware upload that went fine).

Heeeeelp!

Using the latest version of MP (however this doesn't seem to matter as an older version has the same problem).

Using the latest version of Windows 8 (however this doesn't seem to matter as also tried Windows 7 on another computer).

If you find the problem/solution please post. I have yet to replace my APM 2.5 because I don't want to have same thing with pix hawk.

So what is really strange is (discovered while working with 3DR techs) Maxlink words just fine if i uploaded the ArduPilot firmware but not if i uploaded ArduCopter firmware.

That tells me there is a software issue in the firmware.  So i'm not optimistic that the replacement they will send me will work either.  but who know.  i'm hoping beyond reason.

I'll be sailing in the Bay of Biscay for a month, but will try to remember to update when i'm back and test the new one.

happy sailing, I'll be busy for a month so I'll have to remember to look for update.

Did either of you ever figure this out? I am having the same problem and I could desperately use the help!

Yes.  It was a bad mag in the GPS/Magnometer.

When I got the replacement Pixhawk, had the same problem (only had them replace the main computer and not the periferals).  But this time ...

Posted the solution earlier, but maybe it didn't take.

disconnecting all of the periferals and then connected and tested the Mavlink connection.  Plugged in the mag and it would no longer connect.  Has a spare from APM 2.5 and plugged it in.  Worked fine.  Just got my replacement GPS/Mag today.

Thanks,I guess I now will be confident enough to order Pixhalk and hopefully get my hex back in the air.

My latest thing is trying to get Pixhawk to run non-SimonK firmware ESCs.  If you solve that one, let me know.  I'm on the hunt for efficient SimonK ESCs.

Thanks for the response! Turns out I had a 5 wire instead of a 6 wire cable hooked up to my gps. That fixed the problem before I got around to trying out a new unit. 

Great!  Don't you love it when things start working?  

Oh yes! It all makes so much sense once I get it going and then I wonder why it was so hard to figure out in the first place!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service