Thought the problem was a potentially faulty APM 2.6 so unwrapped my PixHawk.  Same problem.

In MP, it connects and downloads the firmware.  Pixhawk then gives the successful happy song.  Select connect via Mavlink:

- starts 30 second countdown

- red connect changes to green disconnect

- timer goes to 0

- continues trying or doing something for another 1 1/2  minutes while countdown stays at 0

- then get No Heatbeat error.

In Windows 8, Device Manager, Com 5 is set to 115200, 8 bits, no parity, 1 stop bit, no flow control, FIFO buffers.

In MP, Com 5 PX4 FMU v1.6 (COM5) is selected.


- restarting the computer

- connecting via a different computer (windows 7 and an older version of MP)

- four different USB cables plugging into different USB connections (getting desperate)

- different com settings

I'm beginning to think i'm in a no heatbeat black hole.  will see if i can setup the radio (but can i do that without mp?)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • ok

    i found this solution

    nothing wrong with gps or any other ..

    i connect lipo to the FC wait couple seconds then connect the usb cable 115200 and putting the right port connects to mission planner right away......then ready to setup

  • i have done all above and i get the following on win 10

    fail to create log...wont log this session  and then i get the usual no heartbeats......

    the funny thing is that i have done this before i had few difficulties connecting but something happened and connected...i thing i played with the b rate 38400 to 57600..........any ideas

  • Hello all,

    I have the same issue. I have a pixhawk board, I could upload AC3.2 firmware but then I can't connect the board to the mission planner. I tried different things: connect/disconnect GPS/compass modul, tried on different USB port, even tried with separate power module but in the end all ended with no heartbeat packets received error message. I don't know what to do further. Please help if anyone can tell me what to do.

    • MR60

      sometimes it's magic.  usually once you figure it out it keeps working.

      i'd call/e-mail 3DR customer service if you feel like you've tried it all.  they are responsive.

      • Thank you, I'll follow your advice.

        • I haven't got support from 3DR, but after reading other posts on the forum, I decided to replace the SD card. After replacing SD card, all things went well.

          • MR60

            well done.

            i wonder if 3DR checks for a heat beat before they ship them out or if they only do a direct connect?

  • If you have the telem module connected you have to power from the flight battery and USB simultaneously. USB alone won't provide enough power.
  • Well, just to add to the mystery, our first attempt at disconnecting the GPS from Pixhawk and trying the Mavlink failed. My friend had disconnected from the GPS end and left the cable attached to the Pixhawk.

    After removing the cable completely from the Pixhawk and also removing the i/o cable from the GPS, we were able to restore the Mavlink. Seemed it needed everything removed from the GPS connection on the Pixhawk. As to why, I'm clueless?!

    • MR60

      If (big if) removing the cable completely had anything to do with it besides coincidence, then the reason is most likely a loose connection on the board that gets tweaked when messing with the connection terminal or a cable with an intermittent short.

This reply was deleted.


Santiago Perez liked Santiago Perez's profile