hi to all, 

 

After several succesfull flights with my Arduplane (v2.26) i have problem.

when i plug my 3s lipo to esc, only a red led(PWR) lights up on ATMEGA 2560 board. When i plug the usb everything works great (except servo movement) and i can play with mission planner and read inputs from all sensors and rc inputs.

 

i may exceded the current trying to use 7 12gr digital servos (4 for flight control-3 for camera). wrong servo throws fried one of my servos and since then the problem appeard (iam not exacly sure if it happend before or after the new firmware update) .

i already checked for the soldered part and its ok.

 

is there eny way to reset a fuse or something? should i buy another fuse or buy another board? power the board using another trick??

 

thanks you all 

James

Views: 696

Reply to This

Replies to This Discussion

Hi James,

 

I'm sure you have, but I will just ask! Did you check this page here

 

And have you looked at this information here

 

You can power the board in another way by following the above steps , I thought that the fuse reset itself after a power down on the APM, I could be wrong!

 

Let us know how you come along with the above information.

 

Regards

 

Martin

thanks Martint 

i already checked all the above:3 dif esc's,fresh lipo, solderd jumpers, usb powers everything, done a fresh radio setup, reset both boards, checked the rc rail for shorts or cuts. power reaches  faintly only the PWR led (and rc rail offcourse)

 tomorow i will try to desolder and  power up everything directly and hope to work. but this mesh up my rc setup.

i was hoping that it was i firmware upload problem or just a little fuse..

 

 

James

I have had a very similar problem. The last time was after 2 good flights. After changing batteries, I couldn't get the yellow gyro, or red GPS led to light. I had no xbee connection. After hooking the plane up to usb I could upload firmware, but couldn't connect to change settings. I could connect to test all the hardware with the MP terminal, all tested well.

I also when over all solder joints on the APM, tried it again same thing.

I then loaded the Hil firmware, now everything seemed to work. I then reloaded the 2.26 again, had the same problem back again. ???

I next loaded 2.24 firmware from the Arduino interface, It rebooted the APM and all seemed to work again.

I have had this happen 2 times both times I had to go to older firmware, then reload the 2.26.

Give this a try and see if it works for you.

Burt

Burt 

 

i wil try it right now!!!! hope it works for me too! thanks you very very much.

i will reply asap.

 

I just tried it... nothing for me :( 

it seems like there is a power cut between rc rail and APM board, because when i plug my esc only the red light (PWR) faintly comes up, not even the servos just jitter for a second!!  and when i plug my usb everything ligths up and working, again nothing to servo rail..

any other ideas??? or similar problem??

 

i found a lead!!!

i conected the ground cable on rc rail and the red cable from balance plug to onboard voltage sensor red... nothing happened,  then i conected the powr cable to rc rail and the ground from balance plug to ground on voltage sensor and everything works!! 

 

so i suppose the problem focus on my ground on on rc rail wright?? any ideas now?

James

Have you checked the fuses on both the IMU & ArduPilot Mega? On the IMU it's next to the USB port. On the ArduPilot Mega it's about center of the board, and on the side the GPS port is.

I was hoping you had the same problem as me, mine seems to work till I trust it again then fails.

Burt

 

Thanks a lot Burt, i was hoping this to work out too.

It seems i have exacly  the same symptoms like Dave Whittington http://diydrones.com/profiles/blogs/ardupilot-mega-home-page?id=705...  discribes a year ago, but my jumpers are solderd.. 

a minute ago i powered apm board from + - holes with a seperate UBEC and aditionally a pluged my esc on rc rail, everything lights up but servos still dont move in any mode..

i cant locate the fuses on APMboard, how the look like/ name? for sure nothing missing i double checked all images with my board

i will have my polymeter back tomorow to check every end..

 

Thanks again for helping me Burt

hi Burt,

I've the same problem you have.

today i've loaded the 2.26 firmware and I can use only the CLI.

my ardupilot won 't start. If I load a previous version it work fine.

may be a bug in the 2.26.?

have you loaded it by the mission planner or else?

Hello everybody!!

 

Problem found and Solved!!!

it seems that servo burnout, burn this little ground line on apm board from rc pins ground to board ground

i solderd a piece of cable from rc pins ground to board -+ holes and everything works again!! be carefull when using many powerfull digital servos with high draw.

 

Attachments:

Thank you so much for finding this!  I have TWO APMs that "died" and I found that both have this same trace burned.

Have you had any issue with the PPM encoder after this fix?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service