No RC Receiver message

3691073617?profile=originalMy first flight today with a amp 2.5 installed in a fpv phantom wing the flight was great in manual .

Though I do have a few issues first is this message no rc receiver in mission planner yet everything is connected up?.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Has anyone ever tried to contact 3DR technician with all there weird APM problems?

    I would think that they would have more answers.

    I'm not sure how much support they would be as I tried contacting them on another issue and was told to go to this forum for answers.

    • T3

      Were the APM's people are using purchased direct from 3DR or were they clones? If they were clones, they don't really have a reason to support it through typical support channels.

      • Bot5h my APM are from 3DR. they have 3DR stamps on them.

  • How did you fix this? If you did.
  • I have had this problem for a long time now. I don't understand why the message says "No RC Receiver" as a result of whatever test it makes. The receiver is there if an arm was attempted resulting in this message. What test failed? A better message here would be helpful.
    • Actually I have had this message and the no heartbeat message on two of my APM 2.5 controllers. I am so frustrated and after trying all the fixes I could find I've decided to scrap the APM's and find a more reliable flight controller.

      Maybe try the NAZA or.....?

      I tried contacting 3DR directly for help but got no where.

      • I have been tempted and may do too. Soon.
  • Ok I now have this problem on my APM. No RC receiver.I got the error when trying to am.I have uploaded the latest firmware,the radio is calibrated properly.I can watch it in Mission Planner.Compass & GPS fix is ok. I changed the parameter to ignore all items before arming.This APM is in a Quanum Nova quad copter.

    It was working previously.

    Any assistance is appreciated.

  • T3

    I got the same message flying yesterday as well. I'm running ArduPlane 2.74b and before I went out to fly, MP said there was an update so I updated. I never had this issue before.

    Regardless, the plane flew fine but every time I had some "warning" message spoken out, it would say there is no receiver before saying the other warning. Without another warning, it wouldn't say anything about the receiver even though the text indicated otherwise.

  • Another thread on this.. somewhere here. anyway, it seems if you update the apm firmware it fixes this.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @sunilmallya: Representation Learning +Instance Transfer to learn new reward functions along with advantage based filtering of new exper…
2 hours ago
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
Apr 27
DIY Robocars via Twitter
RT @f1tenth: Sliding (autonomously) into the weekend like ... 🤖😎 #f1tenth #robots #AutonomousVehicles @OpenRoboticsOrg @NVIDIAEmbedded @Aut…
Apr 25
DIY Robocars via Twitter
RT @chr1sa: One of the problems with autonomous car racing is that watching software drive is not a very exciting spectator sport. To help…
Apr 25
DIY Robocars via Twitter
RT @SmallpixelCar: Replaced AGX Xavier with @NVIDIAEmbedded Jetson Xavier NX. Now both cars look fast and clean https://t.co/jlcoY2EjZf
Apr 25
DIY Robocars via Twitter
RT @chr1sa: Yesterday we had a record number of competitors (36) in our monthly @DIYRobocars virtual autonomous car race. We kept it going…
Apr 25
DIY Robocars via Twitter
Apr 16
DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
Apr 11
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
Apr 11
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
Apr 11
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Apr 7
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Apr 7
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
More…