I had a very disturbing experience a few days ago. One a very routine testflight the X8 conf copter went suddenly in radio failsafe (~289m from pilot) and instead of RTL it started to just...fly around. I have tried both Loiter and RTL number of times before this flight and they both were working. The main question is why it did not RTL?

Some additional info:

*Arducopter 3.2

*X8 conf copter (~17kg)

*Spektrum DX9 + AR10000 (main receiver antenna + 3 satellites) with PPM encoder

*I have been testing different copters in the same spot for over a year, no problems with the spot.

*I have flown over 500m LOS with the same copter and it never lost connection between RX/TX.

About the flight:

I did a forward straight line, stopped and started to come back but on the way back the copter made a sudden movement and started to just fly around. I tried switching between different modes and it seemed that I occasionally had control over the copter (10% of the time). I started running to the copter and tried to pilot it in the same time. After about 3 minutes I somehow had enough control to land it unharmed. 

Could someone shed some light on what might have gone wrong?

Views: 749

Attachments:

Reply to This

Replies to This Discussion

Have you tested the RTL before using the arducopter 3.2?

Have you updated your firmware version from 3.1.5 to 3.2?

I'm asking because I'm having some problems with failsafe and I'm pretty sure that something has been changed in this new firmware...

I've tested the RTL feature with pretty much every Arducopter version of the past 2 years. Yes, I've updated from 3.1.5 to 3.2. 

Well that is what I suspected, I'm pretty sure that something has been changed in the code regarding to failsafe or regarding to the way that the code sees a failsafe triggered by the receiver...

I have a quad with pixhawk and FrSky L9R receiver set to trigger failsafe using user predetermined postion in case of a lost of signal( as can be seen on L9R manual, http://www.getfpv.com/media/wysiwyg/documentation/Frsky-L9R-Manual.pdf ) so my channel 5 is set to RTL flight mode in case of signal lost...

I was using version 3.1.5 for quite long time and everything was working fine, if I turned of my transmitter just to simulate a signal lost, the copter would engage RTL flight mode and return to lunch and land, same as if I fly to far and I lost signal( L9R receiver doesn't have the RSSI signal alarm as it is not a telemetry receiver ).

When I upgraded to firmware version 3.2.1 this same setup stopped to work, copter doesn't engage RTL in case of signal lost anymore, not happy with that and after long hours trying to figure out why it was happening I decided to downgraded back to 3.1.5 and everything is working again as it should so it's definitely something has been changed in the code.

I just feel that this is a major issue with this new version and each day I have the impression that there is more people experiencing this problem...

Now here is the thing, my copter waits less than 2kg... I was reading the specifications of your copter and I'm glad that your got to land it safely.

Wish to have the attention from developers or 3DR to this issue as in my point of view it's a huge concern if we think about the amount of people the would be updating it to version 3.2.1 and just will realise the problem once that they need it working...

I'm by no means expert at log analysis but the log file for the OPs case seems to show that RTL was selected twice as a result of low throttle PWM. On each occasion the throttle PWM was fluctuating, suggesting intermittent RF communication. Each time the log reports distance and heading to a home but I can't see any reason for why the craft apparently didn't head there. Someone else may be able to advise why.

I'm not an expert either, but in the OPs case you could be right if he is using only low throttle PWM. In my case I'm using user pre-determined postion in case of a lost of signal to the receiver as mentioned above and there is definitely a something different in the software that doesn't activate RTL. 

It may be that you have different problems. Do your logs show what actions if any were taken when you ran out of range and should have seen RTL? Were there any error massages?

If you believe that there is or might be a general problem with 3.2.1 in respect to FS then I think it is important enough to warrant a separate thread of it's own. If there's not one already I reckon it would be a good idea for you to create one. It may get more attention if separate.

Thanks for your suggestion Mike, I have now posted a topic about the receiver failsafe issue that I was having.

I made further test and it's pretty clear to me that something definitely has been change in version 3.2.1

If you have time please have a look and let me know what you think.

http://diydrones.com/forum/topics/warning-receiver-failsafe-not-wor...

Hi,

Your 3.2.1 log show you did NOT activate the Throttle failsafe, so it is normal it does not work ! (parameter FS_THR_ENABLE is at zero).

Your problem a misconfiguration of your failsafe parameters and NOT an issue with 3.2.1.

Good day, Hugues. If You replied to RdanielK, then I would like to point out, that he set RX failsafe values to 50% (Roll, Ele, Yaw and Throttle) + CH5 value to RTL. I may be wrong here but You do not have to have Throttle failsafe activated in that situation since the Throttle value is set to 50% in failsafe situation and the copter should change mode to RTL because of the CH5 failsafe set value. Or?

Hi Hugues,

This is not a misconfiguration on my failsafe parameters, and no, I'm not referring to Throttle failsafe. There is something different in the code and that's is for sure, question is what and why... As suggested by Mike I opened the new topic, so let's keep discussing this issue over there. Thanks for your input!

Did anybody find a solution to this problem? I have 3.2.1 and throttle failsafe definately does not work correctly. It always lands no matter what the setting is, RTL, or continue mission. No matter what the setting is the copter lands.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service