No telemetry but good display...

3690950769?profile=originalAs you can see I get everything BUT none of it works!  All the numbers never change.

MP is version 1.2.1 with MAV 1.0, MinimOSD flashed with the Jun 1st release of the MCM and HEX files (multiple times with the FTDI cable from DIY drones).

2 stage power, 12V (cooled by a fan) and the 5V from APM2.

Wiring is confirmed correct.

No micro USB cable is connected.

MP telemetry is just fine, it responds to tilting of the APM2.

I am using a 3DR 900Mhz radio for telemetry.

I suspect something with the character set update, but nothing looks suspicious.

Please help!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I have the same problem, tried with Xbee and an MK Wi.232 module, all have the same problem. The MinimOSD is receiving the heartbeat signal but will not update the telemetry (artificial horizon, GPS lat & lon, etc...) only the "mode" change and the heartbeat is displayed...

    However when both the Rx & Tx lines are connected the unit works (even with the telemetry radio plugged in simultaneously)

  • What are you using to stream the composite video to your computer? It seems as though it works well...

  • Hi Everyone - I had this exact same issue on an APM1 with both 3DR radio and MinimOSD connected.  All looks OK but no telemetry is displayed.

    This may not be your problem, but here is my error in thinking and what I did to get it to work.

    You must first connect the 3DR radio with MP.  I can even power the APM from USB (APM1, rememeber), but I must connect MP and APM FIRST usng the 3DR radio.  Until I connect them, I see heartbeats but no telemetry.  Once MP and APM is connected via the 3DR radio, all works fine.  If I try to connect via USB, no telemetry.  But if I again connect via the 3DR radio, all works.  And one other thing - once I connect via the 3DR radio, I can disconnect MP and all continues to work. 

    So to sum up, you must FIRST connect MP to APM via the 3DR radio to get the MinimOSD to display telemetry. 

    At least, that worked for me.  Since you're on an APM2, it may behave differently.

  • Howdy fellas, yeah, it should not take the OSD anymore than say a few seconds to pop up when you have data streaming from the APM2.  The time interval is dependent on how long it takes the APM2 to get a GPS lock.  Inside my house thats a few minutes.  Another thing that threw me off is that there is a a slightly wrong setup that you can do that will make the OSD display but have no data.  In fact it IS getting data, but WHAT your displaying for information (as in you put a check mark by it on the firmware setup for the OSD) simply has NOTHING to say, like lat and long are all 0's because you have no GPS lock.

    It is a subtle "error" that fooled me for awhile.

    The waiting for heartbeat and not getting it is purely a wrong connection thing.  It will be a wrong connection made to the APM2.  Check it, then re read the setup guide.  Look for pictures of functioning APM2s with the OSD hooked up.  I would provide mine but getting a good pic now is difficult due to the way everything is situated in my bird.

    Let me know if you solve it too.

  • I figured it out, so i'll leave this post for others just in case.  In order to have data being displayed it takes awhile for the data to come through.  GPS lock seems to especially matter.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…