No Throttle Control

Hello Everyone,

this is my first time working with and attempting to run arducopter on an apm 2.8 board. I have everything set up and ready to go, and can arm my motors, but once they start spinning at their idle rpm's (min throttle) any throttle input past that sends my motors off at 1 speed no matter what percentage my throttle is at except minimum (when they shut off back to their idle speed). i have no control over the throttle on my copter, and my ESC's, radio, and everything are calibrated. If anyone has any idea what could be going wrong or knows how to fix this i am dead in the water and ready to quit on this board, so your help is much much appreciated.

Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thank you so much! I don't know how you figured that process out, I had to repeat it more than a couple times but I was able to finally fly, I just ran it in stabilize for about 20 seconds a couple of times, everything banked correctly, pitched correctly, and yawed correctly, but most of all the throttle worked correctly! its too late to fully test it right now but you can bet I'll be up bright and early tomorrow to hit the local RC airfield, then after I get a little more of a feel for it and maybe some PID tweaking I'll embark on the challenge of setting up my OSD and FPV system, hopefully all will be functional by Monday when I go back to work, I am completely addicted to this hobby and the challenges it gives me, I CAN'T THANK YOU ENOUGH my friend you are aces in my book!

  • Yes sir I did! I uploaded ardurover a couple of times, reset the board with that firmware a couple times, then re-uploaded arducopter back onto it, went through the calibration wizard, and was good to go. Swapping out those firmwares erases the EEPROM on your board which pretty much erases its "personality", so things that were acting funny or not quite right could potentially be corrected (if not a hardware issue) and luckily my throttle issue was one of them. Hopefully this is the case with yours as well! You can just google how to erase EEPROM on apm and you'll find what you need as far as how-to's. If you've already tried this or it doesn't help, and you've made sure you've calibrated all your hardware, check your min/max throttle (specific to copter), and throttle rate (which should be set at or near 1000 which allows you to access the full range of your throttle) parameters and verify they're in order. If everything else fails and your dead in the water like I was for almost a month, just spring for a new board because it most likely is a hardware issue at that point.

    Hope this helps

    Taylor
  • Same problem, did you ever get this issue  worked out??

This reply was deleted.

Activity

DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
15 hours ago
DIY Robocars via Twitter
15 hours ago
Derrick Davies liked lisa TDrones's profile
16 hours ago
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
More…