No voltage on Pixhawk aux out pins

Hi - I am trying to set up my Pixhawk to trigger a camera using Arduplane and when I tried to test the voltage step-up circuit described here I noticed that there wasn't any voltage across the +/- aux out pins. In fact the only set of pins with a voltage is the RC IN slot where I have my receiver plugged in. Do I need to set a jumper or change a setting to power those pins? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • The RC in is on a different power rail than the servo rail. You may need to provide a jumper from the receiver to the servo rail to make the camera trigger work. I'm using the same circuit you are but my Pixhawk is powered from the servo rail and not the power module. Does your ESC provide a BEC? If so you may want to use this as a redundant power supply for the Pixhawk if something was to happen to you power module. Check out

    • Thanks Rob.  I connected the ESC to the Pixhawk Main Output pin 8 and now I have ~5v across the +/- pins. I also have the 3DR Power module connected.

      I'm one step closer but now I still can't get the expected 3.3v on the signal pin. I have tried several different configurations in Mission Planner but so far none have worked. I have my transmitter set up with channel 7 connected to a toggle switch and I'd like to fire the shutter when I flip the toggle on and off. I have the RC cable plugged into the Pixhawk Aux Out port 5. 

      I set this up with APM 2.5 on my quadcopter last year with relative ease but can't get it to work with Pixhawn and my plane. If anyone can provide guidance it would be appreciated.

      • Ned,

        I haven't played with the camera trigger with Arduplane just Arducopter so I don't know if it any different. Using Arducopter I picked the option for Relay and it works great. Are you able to check the circuit to make sure you built it correctly? Try it with a 5 volt source and 5 volt trigger to see if it works using a volt meter. Later I'll post a screen capture of my Arducopter camera setup screen.

        • Rob, At this point I don't have the voltage step-up circuit hooked up. I'm trying to get a voltage across the signal pin before I see if the camera switch will work. I expect I'm missing a simple step but for now I'm lost.

          • Strange thing happened. I installed Arduplane 3.0.1 and 2.78b and I can't get the trigger to work. I put the 3.3 signal wire on an oscilloscope and nothing happened. I tried using pines 1 through 6 which is the same as 50 through 54 and no luck. I tried an older version of Arduplane to see if that helped. Once I reinstalled ArduCopter and reloaded my parameters it works perfectly.

            You may want to install arducopter on your pixhawk just to see if you can it working. In the mean time I may do a little research to see if anyone else has this issue with Arduplane on the Pixhawk.

            • Bummer. I'll see if I have time next week to try it with Arducopter. It has been working fine with my APM 2.5 on my quadcopter but I haven't tried installing arducopter on the Pixhawk. 

This reply was deleted.