Not all motors arm correctly

Hello.

I have finally finished putting together my arducopter. Specs are:

ArduPilotMega IMU Shield/OilPan Foxtrap 2.2
ArduPilot Mega
UBlox GS407 GPS
XBee Pro 50mW Module with RPSMA (Series 2.5)
2830-12 850KV 30 Amp motors
Hobbywing Pentium 30A ESCs
APC 10x4.7 Slow Flier x 2
APC 10x4.7 Slow Flier Pusher x 2
3S 2300mAh LiPo
Turnigy 9X 9Ch Transmitter w/ Module & 8ch Receiver (Mode 2) (v2 Firmware)
Motor-motor distance 48cm

This is my first taste of anything RC, so I've had to learn from scratch, so please excuse any newbie mistakes. I have worked my way through the manual and a little stumped on my next problem.

I had calibrated all the ESCs via card and then throttle calibrated through RX. I removed all but one of the red wires from the ESC going to the APM for the 5V power. Mounted all components to frame and accessed it through the Xbee and configurator. I carried out the initial calibration which levelled out the horizon.

I arm the motors and three begin to spin, but the front motor (using the + formation) fails to start until I up the throttle quite a bit, but then the other motors start/stop randomly?

It was suggested that the use of badly soldered bullet connectors may cause this problem, but I've removed this from the the 'slow' motor with no difference.

Any help would be greatly appreciated.

Thanks

calibration.PNG

DSCF4224.JPG

DSCF4225.JPG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi

    Has this issue been resolved ?
    I am having similar issues. I think it is related to the 9x transmitter setup

    Regards
  • @Knuckles904 Thanks for the info but the battery should be fine for the power required. Unfortunately I don't have another battery to test.

    @Chris

    Well I've gone ahead and removed all soldered connections and replaced them with choc blocks for ease of testing and knowing there's no cold joints.

    I've recalibrated all ESCs, changed over the motors etc and have loaded up the latest RC1 code.

    Again, with a different motor and ESC still the same problem of the front motor not starting with the others. On another note, when I tilt the copter left and right the motors speed up/slow down as expected. However, when tilting forward and backwards the motors take a few good seconds to speed up/down. I also verified this in configurator. I'm not sure if this is normal behaviour.

    All motors start when given the command of 1100, however the front requires 1200 to start properly. If it's of any help I have my only ESC power connection through this channel (3- throttle-front motor).
  • I had a problem where one random motor would drop out at a certain throttle. It turned out to be my battery. It couldnt pump out more than 25 amps even though it was spec'd for more than 50. Cheaper batteries dont always give what they advertise. Try a different battery if you still have problems after youve made sure all the connections are right.

    @Chris, What is the RC2 code?
  • 3D Robotics
    Sounds like an ESC calibration problem. I use Turnigy ESCs and have never see that issue.

    You're using the RC2 code?
This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
1 hour ago
More…