Not connecting: 3DR telemetry radios

We just completed our Y6. Unfortunately, the APM Planner 2.0 will not recognize the telemetry, the tilt of the Y6, the our current map location. So, there is no active link via the radio to make all these functions happen. (We did follow the setup instructions in Ardupilot.)Help please.Jack Keegan

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I can't believe the bullshit with these Flight Controllers sometimes.  I just had a perfectly working set of 3DR Radios I had been using a year and a half on four different APM an Pixhawk FC's then I buy the new Pixhawk 2.1 and it won't communicate.  Anyone have any clues to this riddle?  These things are wearing me down to my last nerve.  How could there be a difference,  I have tried switching the Rx Tx wires, stuffing up my nice factory harness, Nothing!

    \

  • Kevin, did you ever get this working? I'm using APM Planner on mac as well. Very similar situation. I can load/save the local/remote radio settings (indicating that the radios are working), but cannot connect in the flight data screen. I'm running v2.0.18 of APM planner. I've got two different sets of radios as well.

  • Thomas, thanks for all the help you have given by being a part of this community. I wonder if I could impose on your good nature a little further. Having followed all your advice I still cannot get my APM Planner to connect to the aircraft. Both LEDs are solid green (3DR radios V2), however, all the published literature shows I need a 6 pin cable - mines only has 5 with a "missing man" pin. As far as you can tell do I have the right cable?

  • Admin

    @John,

    Have you programmed your radios with their operating parameters already?

    I assume that you have the telemetry radio baud rate set to 57600?

    What are the led indications on the radios?

    Have you tried using MP to see if the telemetry radios will work with it?

    I just used APM Planner 2.0 rc3 with my 3DR 915MHz telemetry radios and it connected on the first try.

    Regards,

    TCIII ArduRover2 Developer

This reply was deleted.

Activity

DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
More…