Not seeing radio output through Ardupilot

Hi

I have just assembled the Ardupilot Mega full kit and have started testing it, all seems OK using the latest Ardupilot Mega planner (downloaded today), I can see all movements of the sensors in AC2 Raw sensor screen, but when I go into the Radio tab I can only see movement of the radio on the left "Radio In" but no movement in "Radio Out". I am sure it is something simple (a bit like me) but anyone any ideas.

Cheers John

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Like said before, you must arm the motors pulling the throtlle to 0 and rudder full right, if you have the APM connected via USB, don't forget to connect the battery or you may burn your outputs or usb, since usb does not have enough power to feed the ESCs. Also very important, maybe the most important, remove the props from the motors before doing any of this procedures or you may injure yourself.

  • Developer

     

    You have to put the throttle stick lower right during more than 2 secondes to arm the motors. Be careful when doing this, disconnect ESC signal feeds.

  • You'll only see outputs after you arm the motors.

     

    Basically until the code is actually sending a signal to the outputs it won't show up in the planner.

     

    Just remember, make sure you don't have the motors powered up (or have the props removed) while testing.

     

    chris.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
yesterday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
yesterday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
More…