Obvious compass problem? Crash in Auto

I'm new on the forum so maybe I'm posting in the wrong section.

Yesterday I was out flying with my Tri and tried the mission planner for the second time which resulted in a crash. I have recently "upgraded" from multiwii and my gathered experience on multirotors and RC of any kind is combined not more than the past few months.

Its difficult to see well on the video as the copter is far away and bad camera. Needs full screen to se anything.

My hardware is a Crius AIO Pro with the NEO6M GPS. I have tuned my platform using the autotune and it appears to me that it has got the settings quite good as the platform now is very stable and responsive (maybe overshoots a little but thats within margins).

Last time I ran mission planer it went between points making a "bow" and not a straight line. I narrowed it down to the compass as "simple mode" did not work well either. Stabilize, Alt-Hold and ACRO where really stable but simple and loiter where not.

What I did was move the power cables about 2cm further away from the board and yesterday the "simple mode" worked like a charm. I was also getting nice straight lines in mission mode but all of a sudden a crash.

Just before the crash it followed waypoints really well until it seemed to miss one (pass by) and then it entered a circle I was not fast enough to save it from. What surprised me was that the copter dit not do circles in the air as before when loiter was messed up but instead it circled to change its inclination so much that it fell. I thought that it was always in stabilize when in AUTO. Anyways.. unfortunately I don't have logs activated to save some space on the FC and also to get better performance. What you can see in the pictures below is just a print screen from the video but shows on my phone how the copter went in straight lines and then circled before the crash.

3691147007?profile=original

3691146983?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • it's more prone to circles (toilet bowl  effect)  at speed, and depending on yaw angle.

    anyway, from the little screenshots and video you posted, yes - this was a typical behavior caused by bad compass.

    Upload your logs to droneshare.com  and you'll get that verified very quickly.

    Redo compass calibration, heed warnings about high offsets, move compass away from power, and have fun.

    • Thank you for your reply Andre. Unfortunately I had logs off during the flight. I've ordered a new GPS module with compass as to get it externally. Also will look into moving the power lines even further away. My offsets are -4.873394 in Z -5.813363 in Y and 88.492294 in X.

      Two questions..

      1. how do I do a compass calibration on the field, have not found it in mission planner for Android that I am running but only find it in mission planner on the computer.

      2. Any idea as to why the platform went beyond the lean angle and crashed? Is this normal when compass fails? 

      • 1: try droidplanner too, suggest for both authors to add this feature (not sure if droidplanner is still missing it)

        - APM planner can do that to, (in case you have a laptop with something else than windows)

        2: hard to say if it did, without logs / version.  recent versions prioritize altitude over speed. the high speed is a result of not getting closer.

        • I think I might have solved the problem. I lifted the FC quite some bit from the power lines. In the picture below you see the white plate beneath the yellow dampers is new. Before they where mounted on the purple plate next to the carbon fiber below. Flew around in stabilize asking a friend to look at the compass on the ground station to see if it seemed to be accurate. Tried full throttle many times and it did not go bad. Tried loiter and it was stable. RTL also worked like a charm and land as well. Did not try any waypoints.

          3702765491?profile=original

          I had another problem today though. The system started oscillating at times being almos impossible to control. It seemed to be when it either was further away (50m) or when battery was low, have to do more analysis. They where some new things on the platform though. I have added led stripes and telemetry kit (had bluetooth before). Running 3S batteries and suspecting its not enough, strange though that it seemed to appear when further away. Any guess?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…