OS X El Capitan upgrade now can't connect via USB

I have upgraded from Mac OS X Yosemite to El Capitan. Now I can not connect to my APM 2.8 using mission planner 2.0 on the Mac.This is true for both wireless module and direct UAB cable connection.I can seed the wireless device on the Mac OS X configuration under system info. But the Mission planner software can't connect and eventually times out.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I cannot get APM Planner 2.0 working on new iMac on latest El Capiton.  

    It does not see USB port.  Only reports "Bluetooth Incoming Port"

    Tried reloading drivers.  Any help is appreciated.

  • The unix based operative systems, sometimes, need the apps run on 'root mode' to access the COM ports. I had that access problem on Debian Sid. I just start the apmplanner2 from terminal as root and with this the problem is solved, but you have to know the risks using root modes.

    You can try to start the app with a terminal, something like 

    sudo open “/Applications/Utilities/MissionPlanner.app”

    • Developer

      You don't need to run APM Planner 2.0 as root. (OSX or Linux)

      You do need to add the user to the correct groups on Linux you need the user added to the 'dial out' group. and remove modemmanager.

      I'm using El Capitan with 3DR Radio and it seems to work as expected. Though there are people who are reporting issues why is unknown.

      (I am the lead dev on APM Planner 2.0)

      • Thank you

        I had a problem with this, the Modem manager was not a problem on Jessie but I had this on Sid.

      • Developer

        As to a resolution, I would suggest a clean install of OSX El Capitan to see if that solves the problem

  • massive bug in El Capitan serial interface.  No fix is available.  Good luck 

    • 3D Robotics

      I'm using El Capitan on a Macbook Air with no issues. Works great over USB with APM Planner

      • Good for you bad for us.  

  • Thanks,
    I did remove it and reinstalled. I also tried GRound Control station.
    Something has changed on the way El Capitan access the USB port?
    The computer I'm using btw is:
    MacBook Pro 15" 2.5gighz, 6gb ram, 750gig
    Late 2008 model.
This reply was deleted.


David Hori liked Isabella Domi's profile
gotham liked gotham's profile
Dec 3, 2020