Pixhawk 2.1 (cube) unreliable? Not stable with ArduCopter? Odd behavior with Rangefinder Sensor

So I am starting to think the Pixhawk 2.1 is simply not reliable or ArduCopter is still not stable on them. I so badly want to like them but every build I do with one there is some problem or another.

Here is the deal. I am building 2 identical drones. Both have Pixhawk 2.1 units obviously.

I am using a TF Mini Lidar for simple avoidance - on the first unit it worked both serial and with the i2c Arduino mod.

The second unit refuses to detect it in either configuration - even tried cloning the working config. Tried reflashing the firmware, resetting to defaults and a host of other diagnostic steps including flashing the PX4 stack and reverting back to AC3.5.5.

The odd thing is that if I unplug the GNSS and plug in an external i2c LED it works fine (by design the LED will not work when the HERE GNSS is plugged in). The telemetry 1 and 2 both work fine for the 915MHz transceiver so I am doubly confused.

The only difference between the two units is that the working one has an Edison carrier board (no Edison) and the other does not. The one that is the “standard” is newer.

The system refuses to acknowledge there is a LIDAR attached. Nothing works. I even tried changing the base address in the Arduino hack. Serial is no joy as well so I am lost here.

How can i2c be working for an external LED and serial be working for serial telemetry but not for a simple LIDAR that works fine on another 2.1 running the exact config and firmware?

If I enable CLI on the misbehaving unit I can test the rangefinder and it gives accurate readings. It just refuses to show activity in Mission Planner. It is as if the rangefinder code is not loading unless manually triggered by the CLI test. Is that even possible?

One indication of that is if you enable a LIDAR rangefinder MP should complain about bad LIDAR health if it does not “see it”. This is not happening on the unit that is giving me issues.

I am confident I2C is working and that the serial ports are working since I can use GPS, Telemetry and the external I2C LED. Like I said; it is almost like the rangefinder code is simply not running (I am sure there are drivers or something in the firmware to interact).

Is this at all possibly a software issue or hardware? I just don’t get it. I am both confused and frustrated at the now 19 hours I have spent on this.

Any help would be greatly appreciated.

Views: 91

Reply to This

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service