Pixhawk AUX RC pass through

I am trying to run servos off AUX1 and AUX2 outputs on the Pixhawk. 

I have enabled RC9=1, and have been able to get a servo to respond on the AUX1 output of the pixhawk. So naturally, I would assume that I could go RC10=1 and get another servo to respond on AUX2. 

Not so naturally. 

oddly enough, on the my transmitter (Hitec A9), the switch that controls pxihawk AUX1 gives no indication on Mission Planner's radio calibration page, yet the servo still runs. The switch that I would like to run the other servo gives a radio calibration page indication but does not control the servo on Pixhawk AUX2. 

Aurora 9 

Channel 9=AUX6=Pixhawk AUX1 with RC9=1 WORKS!! 

I guess I need to know how to wake up Pixhawk AUX2. What gives?

I have tried setting RC9-RC14 to 1 and plugging the servo into each of them but it will only work on Pixhawk AUX1

Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Guys if i want to control servo or led on RC12/RC13/RC14  i.e. AUX pins 53/54/55 using mission planner what should i do. ?

    Because the Mission planner "Servo" Tab has only control for RC5 - RC11.

    please let me know if i can modify anything in the Mission planner software ? 

  • Following up on this topic to see if anyone has figured it out.

    I have an 8 channel radio (FS-THX9X) talking to a PIXHAWK with 3.3R8 firmware and I want to use CH8 to control RC9 (AUX1) for servo actuation.  I have all the parameters setup yet getting no activity.  I've tested the servo with another receiver and works just fine.

    I've read all different posts related to this same goal and cannot put this puzzle together.

    I would appreciate a nudge in the right direction.

  • Admin

    @Sky,

    Have you adjusted the BRD_PWM_COUNT to reflect your use of the AUX outputs?

    Did you follow the Wiki instructions for using the AUX pins Link

    Regards,

    TCIII AVD

    • I have not messed with BRD_ settings. Oddly enough I am getting the desired response on AUX1. 

      I'll go mess with BRD for RC10

      • In any event, no matter the BRD setting, AUX1 and AUX2 stay the same. Shouldn't enabling RC10 turn on the servo function of AUX2?

        • Admin

          @Sky,

          Do you have RC10 setup as a pass through?

          But, isn't your Aurora only a nine channel transmitter?

          Regards,

          TCIII AVD

          • RC10=1

            The radio is just 9 channel. 4 motor channels 1 flight mode channel and 1 (working) servo channel leaves me with 3 unused channels. Surely RC10/AUX2 doesn't have to be an actual Transmitter channel 10 right? Couldn't it be TX channel 6,7,8,9? I've been able to control RC9/AUX1 from channel 8or9 on the Aurora. 

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…