PIXHAWK - command was denied by the autopilot

This is the fourth quad I'm building. The first three have used 2.6 APM successfully. Now when mounting a new quad with the Pixhawk, I found the famous phrase:Command  was denied by the autopilot (when I am testing the motors)
I did and redid everything and I can't hit. Already researched in all forums. Someone decided to reinstall the Firmware 3.1.5. I tried and nothing.There is a list of likely causes for this message from hell. I need help and thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • mira tengo ese mismo problema. por favor alguien lo ha poddo soluciona ?
  • Very simple. Hold down the safety button until  get solid red. Then everything will be OK.

    • I need help with this issue... I lost my safety switch in a crash, and I have it disabled (BRD_SAFETYENABLE 0). However, I am unable to perform my motor test because of this same error message. Is this a bug? APMCopter 3.3.1

  • Motors and esc are working fine and are calibrated. The throttle works normal in calibration mode of esc. HELP !

    • tengo el mismo problema. a veces me da por pensar que es el transmisor mal calibrado. pero al conectarlo por fuera de pixhwk funciona bien
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25