Pixhawk compass calibration does not work


When trying to calibrate the Pixhawk compass, I go to the comapss calibration tab and click the Live calibration, it asks if my firmware is higher than some version and i click yes because I have the newest one, and the sphere screen comes up.

It collects 3 samples instantly and when I move the copter around, nothing happens, nothing rotates in the screen, no samples are collected other than the 3 from the beginning.

I have tried different computers, all the different APm with external compass and so on, this is a Pixhawk with U-blox GPS with compass (genuine 3DR)... Please help!

The flight data screen shows, when i tilt the copter the artificial horizon moves and everything, i get GPS lock, but the calibration does not work... And I get the PreArm compass not calibrated.

I tried loading Plane and then reloading copter again with no luck. I did manage a compass calibration when I first connected the board, but that was before i connected the external GPS/Compass.

So i tried disconnecting the I2C cable, and then it works fine. So it's only with the Mag to I2C cable connected that it just stops calibrating.

Also tried switching the I2C cable, and going through the I2C splitter, no luck.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello,

    Had a similar problem lately.  It was the 6 to 6 wire DF13 cable between the Pixhawk and the GPS/compass unit.  They ship it with a 6 to 5 wire cable for another application that will cause you a big headache.

    • I actually did originally plug in the wrong cable, but caught the error before I finished hardware setup. I had the correct cables before doing the firmware setup.

  • I just received my latest Pixhawk kit yesterday direct from 3DR (after a two week delay) and experienced almost the exact same situation. I have tried to get the compass calibrated on both Mac and Windows without success. I have a ticket opened with 3DR. I will update when I have more information.

  • I had a similar issue with accelerometer calibration. 3DR is replacing pixhawk, but its been several weeks now and hasn't shown up.

    hope the quality control and lack of parts isn't a sign of things to come...

  • I had this problem last night.  I'm building a Hexacopter and am using a GPS/Compass off of Amazon (Andoer Ublox NEO-6M High Precision GPS Module Built-in Compass GPS Folding Antenna Mount Holder for FPV Multirotor Quadcopter APM Flight Controller Part)

    I finally unplugged it and re-plugged it (both plugs) and got the Axis's rotating.  The calibration was tough, but I was glad to get it working.

  • 3DR Support saw this is an RMA, waiting for replacement now.

  • I made this short video describing the problem


This reply was deleted.