I have been using pixhawk succesfully for a week now BUT...

today after a small flight indoors ... after i dissarmed my quad i couldn't arm it again from safe button.

I didn't have the buzzer on so i had no indication of the problem. So i decided to plug my pixhawk on my pc through usb without everything (later on i connected the buzzer and safety switch) and it could not connect to apm nor mp.

After pluging the buzzer i heard this strange beep sequense that is not listed in the known ones so please if someone can help me ... it goes 3 quick beeps and then 3 long beeps like beep beep beep - beeeeeeep beeeeeep beeeeeep . The safety switch blinks fast.

If while it beeps i press the "Flight management reset button" next to USB , then pixhawk comes alive and i am able to connect to both apm and mp.

And WHY does it get OK when i press the "Flight management reset button" ?

Of course pressing the "Flight management reset button" is not a normal solution for when i am on the field , so PLEASE HELP ME !!!!

Views: 13984

Reply to This

Replies to This Discussion

Check your SIM card has not gotten unplugged.

Your MiniSD you mean?

Is there an internal connector in the PIXHAWK casing which could get lose ?

I have the exact same problem as Yiannis with mine version, and indeed the sound pattern look like to match with a missing MiniSD card (P.s I am newbie to this PIXHAWK stuff)

I have taken out and in the sd card a couple of times after the incident , but problem seems to inseast. For some strange reason though , sometimes it starts ok but most of the times it doesn't

I have tried the exact same thing, without any success yet.
Maybe swap the microSD for another just to see what it is doing, but I guess the firmware may use the card to boot up, which could mean that I would need to flash the PixHawk again...
As long I am in the build up phase of my drone I can live with hitting the reset every now and then, but I would love to hear the real reason of this behavior !
Ok switched the MicroSD for another one, and quess what, boot up without any problem...
Didn't even had to bring the files over from the original one...
As it is much larger as the original one 32GB and it is in use for the FPV cam, I guess I get myself a 2 GB version if this booting up keeps going well...
Why the original gives these problems I don't have a clue as I could read all files from the card to the PC...

did you do any special format on the card ? i mean do i just buy a small sd and plug it in ?

If you put the MicroSD in the USB card reader which has been delivered as part of the PIXHAWK, you can read the contents on your PC.
Then If you go and select the card under properties you can find it has been formatted with FAT32.

But guess what I think I have the solution for you...

after I loaded the large card, in the PIXHAWK, and managed to do an successful startup, I was very interested in the files which were on the card after this successful boot up.
So I read the card on the PC and found a main directory called APM, with an subdirectory Log...
After checking the different directories and file content in the directories I found one log file. On the new card, and some sort of initialisation file with some startup text from the APM.
But I also found 2 BIN files in the log directory on the 2GB card (original), which I didn't had on the test card, which successfully booted.

Then I decided to remove these bin files, and try the original card again..
After that the original card also allowed a successful boot up process...

So somehow a bin file on the card is used as initialisation of the APM which is causing our failures..
I guess there had been a situation that these BIN files got written to these cards from the mission planner as that has been the only thing talking to the PIXHAWK.

I guess that it is some sort of dump which should be used by a specialist and should be removed after sending...

So I hope you see these files as well... (If you are afraid to delete, just copy them to the PC, so you can place them back), but I am pretty sure that it will solve this problem.., at least I had just my maiden flight in the garage, hovering and hitting the walls every now and then ;-)

thx alot for the info pal .. i do have this bin file ( i think one) and i will erase them to see what happens .. Hope to work as well as it did for you. I appreciate your response

Hi Yiannis, did you get this sorted, any repeats?

I've keep getting this problem too, with thee short beeps, thee long beeps and sometimes accompanied with a yellow flashing LED. It seems to happen when I change batteries, at least that is the case so far. Scenario: I am flying the quad, I plug in a new battery and then it starts with the thee short, thee long beeps just as you've described. I've already tried removing files form SD card, reformating SD card, re-seating SD card etc..  it's a very annoying issue. It's happened a few times already to me.. seems that simply resetting the whole board and reconfiguring fixes it for a time.... but this really should not be necessary.

https://www.dropbox.com/s/p6lbi65pzpfys7i/2014-03-08%2009.23.21.mp4

I just got response from 3DR support.. 

"That well known sound pattern is regarding a mission SD card on the autopilot. please be sure that your Pixhawk has it microSD card already inserted on it slot before power this up."

No kidding, but if my SD card is properly plugged in and I've check the SD card on my computer several times, what is causing the problem?

I don't know if Yiannis is still experiencing this problem, but for me I can confirm that I do have this problem every now and then.

For whatever reason it keeps getting back, even after formatting the SD card, or repairing the file system on the card by running a chkdsk, which was mentioned at the APM community.

Check disk keeps coming up with failures found on the card, so after completing the FS check it seems to be OK, which results in a normal start of the PIXHAWK.

Usually the PIXHAWK will the boot for a number of times without a failure, and then it starts again.

Did you contact 3D robotics by mail or at the APM community ?

I would love to know the real reason....

Erik, I also performed a slow format and a disk check including bad sector check, no problems found at all...

The engineer asked me to swap out the PX4 SD Card with another one, so I used a SanDisk 2GB Micro SD I had on hand, performed the same process of fat32 slow formatting, disk check with bad sector check and put that in, no problems at all. I can in fact swap back and forth between the shipped PX4 SD card and my own and every time I get panic alarm with the PX4 SD card and the SanDisk card has no problems...

I am now using the PX4 SD card in my video camera where the SanDisk came came from without any problems..

Go figure.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service