Hi everybody.
Several months building a large quad with pixhawk px4 fmuv2 installed, and long range video transmission, with a gimbal, and powered by a large 22volts 12000mah battery. The whole weight is 4kgs, and the quad flew for continuous 35 minutes. I was very happy about the long flight time and its good stability. Until last week, and just the second flight when I was trying video recording above a lake, and after 5 minutes flight, the quad began to wobble crazily, and I couldn't control it before it was falling into the lake and sunk. After five hours, I was able to extract it from 3 meters under water ,using a water bike and following last GPS position in QgroundControl.
After reviewing the log, and connections, I concluded that the cause might be a disconnected wire from the power board which touched the board and caused it to burn, although the ESCs were directly connected to the battery and the pixhawk directly to the power module.
I disassembled all the parts,clean, brush,dry.. and I was happy I could recover all of them except for the pixhawk.
After first connect to Pc via usb port, it was powered normally, all leds and main light were functionning OK. But I couldn't power it from battery. Another thing was that I could install the px4 firmware on it but not the arducopter and the main led light never lit. And after a stupid try of installing px4io bootloader from sd card, the pixhawk was no longer seen from MP or Qgroundcontrol, I tried the python loader , it gave a message "waiting for the bootloader" although I tried to hold switch while powering the pixhawk.

Note: the leds status when connected to pc in normal mode:

IO POWER AND FMU POWER:ON
IO B/E: ON
IO Act: blinking

When in boot mode
IO POWER AND FMU POWER:ON
IO B/E:blinking
IO Act: OFF

Images before a20200212_215731.jpgnd after crash and log file are attached
Any help to recover my pixhawk back and also resolving powering problem from battery will be really appreciated.
Thx in advance

20200317_154851.jpg

20200317_175513.jpg

CrashLog.rar

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Activity

Joseph Udofia liked Joseph Udofia's profile
Wednesday
DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
More…