Pixhawk PWM input for RSSI (EZUHF)

Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.

Steve

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • This is for a Pixhawk setup.

        Edit: For the APM I connected ch8 from EzUHF directly to the APM, slightly different setup. And slightly different setup in Mission Planner as well. As I remember, ME was excatly the same (maybe some different min/max values for RSSI min/max albeit).

  • ArduPlane:

    Got the EZUHF RSSI/Link to work with my Skywalker APM 2.6 plane.

    The RSSI has inverted values and extra percent sign problem but it works!

    What I used:

    EZUHF TX/RX firmware v1.50

    ImmersionRC Config Tool v1.40

    MinimOSD firmware Extra Plane v2.4 Pre-Release r719

    Config Tool for MinimOSD v2.4 Pre-Release r727

    No settings needed to be changed in the APM Mission Planner

    RSSI MIN/MAX 993/1650

    Link Quality MIN/MAX 1074/1794

     

    • trying to set this up and I find when I assign EZUHF LQ to channel 8 I lose my flight mode selection

      Using the latest APM plane on an APM 2.6

      Any clues Gents, this is driving me spare!

      Ross

      • I moved my flight modes to a different channel.

        Look a about time code 2:17 in this video for the schematic and explanation:

        https://www.youtube.com/watch?v=rh7-D96FIK0

        • Thanks David

          I have watched your Video a couple of times, very well presented

          I am using CPPM and want to keep it that way

          My problem is I cannot figure how to switch my Flight mode select channel to anything other than Channel 8 (I'm using Arduplane 3.2)

          I note in your schematic you use channel 6, how did you change that from what appears to be the default of channel 8

          To confuse the issue more the current setup wiki says to use channel 5 which doesn't work for me

          • I changed the flight mode channel input from the default 8 to 6 in the mission planner and then wrote the settings to the APM. 

            • for the nth time I looked and found it

              all good now, many thanks David

              • Oh! well I am glad you found what you needed.

                You would think it would be on the flight mode screen, right? But noooooo way.

                Just to recap for others, I changed the flight mode channel under config/tuning under the full parameter list. Look for FLTMODE_CH. (APM must be connected first)

                Where did you find it? 

                • I had looked in Mission Planned a few times with no luck, it must have been sticking in my face. I remember looking at the param's at the four major flight controls assignments which are the very next ones. DOH!

                  Funny, the first time I looked at the list in the wiki I found it straight up

                  Must be dyslexic or something :)

                  Thanks again for your help 

            • Got That

              Please forgive my stupidity but I am asking how to do that

              What parameter are you changing and where do I find it?

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…