Pixhawk PWM input for RSSI (EZUHF)

Gents I need your help.

I recently upgraded one of my 2.6APM powered quads to a Pixhawk.  One of the reasons I went ahead and did this is because the Pixhawk is supposed to take PWM RSSI signals directly (into the Sbus port aka Pin 103) and I could ditch my PWM to analog conversion circuit is used in my APM.

I have verified that my EZUHF receiver is outputting RSSI in PWM form on one of the channels. (it will move a servo appropriately when the RF gets weak or disappears... and it worked fine for the APM as an RSSI input via a PWM to analog conversion circuit)

And, I have hooked up the PWM RSSI output to the Sbus port (pin 103).... it does nothing.  Shows zero RSSI on the OSD no matter what.

I can't find any useful description of how to configure this in the wiki, mission planner or this site.

How do you make a Pixhawk show RSSI from a PWM input on pin 103 as its advertised?

Thanks for your help.

Steve

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • This is for a Pixhawk setup.

        Edit: For the APM I connected ch8 from EzUHF directly to the APM, slightly different setup. And slightly different setup in Mission Planner as well. As I remember, ME was excatly the same (maybe some different min/max values for RSSI min/max albeit).

  • ArduPlane:

    Got the EZUHF RSSI/Link to work with my Skywalker APM 2.6 plane.

    The RSSI has inverted values and extra percent sign problem but it works!

    What I used:

    EZUHF TX/RX firmware v1.50

    ImmersionRC Config Tool v1.40

    MinimOSD firmware Extra Plane v2.4 Pre-Release r719

    Config Tool for MinimOSD v2.4 Pre-Release r727

    No settings needed to be changed in the APM Mission Planner

    RSSI MIN/MAX 993/1650

    Link Quality MIN/MAX 1074/1794

     

    • trying to set this up and I find when I assign EZUHF LQ to channel 8 I lose my flight mode selection

      Using the latest APM plane on an APM 2.6

      Any clues Gents, this is driving me spare!

      Ross

      • I moved my flight modes to a different channel.

        Look a about time code 2:17 in this video for the schematic and explanation:

        https://www.youtube.com/watch?v=rh7-D96FIK0

        • Thanks David

          I have watched your Video a couple of times, very well presented

          I am using CPPM and want to keep it that way

          My problem is I cannot figure how to switch my Flight mode select channel to anything other than Channel 8 (I'm using Arduplane 3.2)

          I note in your schematic you use channel 6, how did you change that from what appears to be the default of channel 8

          To confuse the issue more the current setup wiki says to use channel 5 which doesn't work for me

          • I changed the flight mode channel input from the default 8 to 6 in the mission planner and then wrote the settings to the APM. 

            • for the nth time I looked and found it

              all good now, many thanks David

              • Oh! well I am glad you found what you needed.

                You would think it would be on the flight mode screen, right? But noooooo way.

                Just to recap for others, I changed the flight mode channel under config/tuning under the full parameter list. Look for FLTMODE_CH. (APM must be connected first)

                Where did you find it? 

                • I had looked in Mission Planned a few times with no luck, it must have been sticking in my face. I remember looking at the param's at the four major flight controls assignments which are the very next ones. DOH!

                  Funny, the first time I looked at the list in the wiki I found it straight up

                  Must be dyslexic or something :)

                  Thanks again for your help 

            • Got That

              Please forgive my stupidity but I am asking how to do that

              What parameter are you changing and where do I find it?

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…