I've setup my Pixhawk PX4, with allot of issues. All of which are solved but one now, the GPS works, its stable in stabilised mode, however when I switch to POS hold, it pretty much drifts off, well I wouldn't say drift, more like thinks the position of the drone is somewhere else so tries to fly off so I have to switch back to stabilised mode.

I will note the compass direction is way off, its off about 100 to 90 degrese. I've done tons and tons of calibrations for the compass all of which its passed in the QGroundControl. But still shows the compass being very off. And yes I calibrated outside away from any magnetic interference from my desktop or electronics.

Could someone help me?

Views: 63

Reply to This

Replies to This Discussion

Solved, I moved to mission planner - Performed a new firmware install using the latest stable X Quad and the compass seems to function correctly - Position hold works just fine now :)

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service