Hi

I`m trying to get Mission planner connected to my Pixhawk through RPI using UDP protocol. But somehow it fails. If i`m using APMplanner 2 everything is working and connections is good.


When i hit the connect button in mission planner it`s saying "waiting for connection" and sometimes its starting to count down and sometimes its start`s to receive packages for a couple of seconds, but ends up in "connect failed" error.
I`v been trying several types of UDP server in my RPI with same result.

  1. Python udp script
  2. TTL to Ethernet adapter, running UDP redirect in RPI
  3. Mavlink,

I tested my old APM 2,5 board instead of Pixhawk, and its work like a charm.
What is the different between APM and Pixhawk telemetry packages.

If i`m using Pixhawk and Mavlink, it sometimes connects successfully 1 out of 10 times maybe, but the latency is very high.

With TCP connection there is no problem at all APM & Pixhawk connects perfectly. Everything running smooth..
TCP tested method`s:

  1. Ser2net- Working perfect (Tested without TTL to Eth adapter. TX/RX connected directly to RPI)
  2. Python TCP script -  Working perfect (Tested without TTL to Eth adapter. TX/RX connected directly to RPI) 
  3. Socat comand line ( socat UDP4-RECVFROM:14450,fork UDP4-SENDTO:<DynDns>:14450

So my question is:
Why is UDP working in APMplanner 2 and not MP?
Is there something else i need to considerate when using PixHawk UDP and MP
I will try to use Wireshark to see whats happening to my package, but i could really need some advice on what to look for.

Regards
Bernt Christian Egeland

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi
    I finally solved my issue..
    If i recycle the power for pixhawk 2 seconds before i press download Firmware, UDP works like i charm..
    I really don't know why this procedure would make any different.

    Have a great summer and enjoy flying. I certainly will.

    Regards
    Bernt Christian Egeland

  • Developer

    can you please try the latest MP beta.

    help > update beta.

     

    and tell me the error you see now. it should be a different error than last time

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…