Views: 13738

Reply to This

Replies to This Discussion

Hi, I have problem with my Pixhawk and esc Emax 12A Simonk. When I connect it to receiver directlly it works, but when through pixhawk, all servos work but esc and motor dont emit any sound and have no any movment. Have no oppertunity to try with another one ESC but such situation confused me! Have you any ideas how to fix problem?

Having same issue

I'm also having the same problem.  Whats even more interesting as I fly a tricopter, if I hold the right yaw and min throttle the tail motor spins up for a second.

Pixhawk is a clone

Running v3.2.1 - will try other versions shortly

ESC's are EMAX BLHELI 30A Opto's

UBEC powering the 5V rail (5.15V)

Was working fine on turnigy plush previously, just switched to new motors and new ESC's

If I plug an esc into the receiver direct it does play the normal sounds and reacts to throttle controls, motor spins to the controls.

Status screen shows CH1/2/3OUT with valid values, same with CH7OUT.  CH?IN's are good values

Unable to calibrate the ESC's in an all in one method, one has been calibrated separately, but it made no difference.

Can arm and disarm as normal

Motor test results in it arming, no motor activity and then a disarm.  As you would expect with this issue.

About to turn on nearlyall hit the logs but since everything looks normal I dont hold high hope it will help.

lets try that again with some commas...

About to turn on nearlyall, hit the logs, but since everything looks normal I don't hold high hope it will help.

i think pixhawk sends the signals using ppm but the esc is not able to read them properly. probably the calibration for ppm is different i will have to check with a oscilloscope.

Pixhawk takes in PPM but it outputs PWM on the motor & aux channels.  But it is definitely doing something different.  If it outputting PPM it wouldn't have taken as long to get the PPM Out working in ardupilot 3.2 or was it 3.3?

have u tried older version of apm firmware

I think in my testing I dropped back to 3.1.5 and it didnt appear to change.  Also tried the beta version, cant remember which one.

Update: Did it again to be sure, yes same symptoms under 3.1.5

Quick question for those with this issue, my ESC's are opto's and I have the 5V rail powered by a separate UBEC.  There doesn't seem to be any data for my ESC's on how much they draw, I assume very little as it is for signalling purposes.

Just trying to see if it's an opto or BLHeli or a BLHeli Opto talking to pixhawk issue.

my esc's are not opto

Cool, so we can reasonably rule out a power issue flowing back to an opto.

I'm wondering if it has to do with the update rate at which the Pixhawk puts out the signal?  Maybe the EMAX BLHeli ESC's dont like it?  I think that was configurable, I'll have a look.

RC_SPEED is the parameter I was thinking of and I've tried 490, 400, 250, 50.  It had no impact so its not likely to be that, unless they have a particular value I havent tried....  Its getting late here, so I'll mostly likely have a look again tomorrow.  I'll try them hooked up to an APM I've got floating about to see if it also has the same issue.

Anyone else have any ideas of what to try?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service