PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Assembled, connected the wires, DSM satellite works with 3.4-rc1 as well (I only miss the failsafe option). So far, everything is good, i haven fly it yet.

    These are some photos of the drone: 

  • Yesterday, before receiving the real one, i managed to fly with the clone using 3.3.4 stable fw. It took like 100 times to flash with different firmwares, once it started to 'work' again at a level where i could take off. So it flies, but has issues with wifi, DSM RC input, and i dont yet know what else. Its still not tuned, but i dont see it as a huge challenge (at least for now).

    The drone was already assembled, soldered, etc, using an APM mini. Its a ZMR250. Now i replaced the flight controller, moved to 4s 2200mah, 16A BlHeli-like sh*tty opto ESC, 2204 motors. 200mw vTX, wide angle cam and a tilt servo. Im using an ublox neo-6m gps (mostly for RTL or position hold when i need an extra hand). I will post some photos of it soon. 

    Before you say, yes i know.. this may be overpowered now, not suitable for photography nor racing (because of may extra weight). These are not my intentions. I just like to hack it.

    Beside of this i have HJ-H4 reptile frame, with old APM 2.6, 30A 4in1 Emax esc, and a DSLR gimbal (which belongs to one of my friends). This is currently not assembled, Im going to add a pixracer there as well in case it works well in my ZMR.

    Now, you will have to learn soldering.

    This part is done, im a bit unexperienced at soldering SMD size parts. But this will not change any soon... : )

  • The PX4Lite gold has also a metal case and works well.

    Perhaps negativ the weight or positiv because of dampening and crashproof.

    Now, you will have to learn soldering. I assume, there are no suitable cable.

    I had 4 weeks trouble to tune Pixracer. Autotune did not work. AltHld was crasy.

    Finaly I found that the "genuine" GPS from 3DR was the issue. On Pixhawk it worked perfect.

    Replace with this:

    all troubles where gone. 16 Sats, hdop 0.6

    On what Frame intend you to instal the Pixracer?

  • I just received my genuine pixracer from AUAV. Just installed ArduCopter 3.4-rc1, the initial tests gives good results. So far, everything seems to work related to built in sensors. I will test it in action soon, will update.

    As now I have a genuine and a clone, i can compare the two (currently on a package-contents level):


    received a lot of cables, more than i need. All of them are nice, soft silicone with reasonable length and great quailty.

    no sd card, no pixracer case. This in expected.


    i received just-enough cable to connect the essential sensors, not all of them are silicone, and they are way thinner.

    4gb low quality sd card, nice metal case for pixracer.

    from the Chinese version, i mostly like the case. maybe i will keep that part. Do you see any disadvantages using a metal, probably aluminium case for PixRacer?

    At the same time, i like to thank you guys at AUAV and here on this forum for all the support provided. :)

  • Another question:

    I have the px4Flow sensor working on a PixHawk on the I2C port, but the same sensor does not work on the PixRacer I2C port.  Is there a code reason for this?

  • Marcell,

    Thanks for your response.  I do see that in the boot log file (rc.APM), but I was wondering how it was handled in the actual initialization functions.  I'll keep looking into it.

  • @Jared: With the latest ArduCopter master, i can see this in the boot log:

    Starting APM sensors
    MS5611_SPI on SPI bus 2 at 3 (20000 KHz)
    MS5611_SPI on SPI bus 1 at 3 (20000 KHz)
    ms5611: no device on bus 3
    ms5611: no device on bus 2
    ms5611 started OK
    adc init done
    adc started OK
    Starting FMUv4 sensors
    HMC5883_I2C on I2C bus 1 at 0x1e (bus: 100 KHz, max: 400 KHz)
    Have external hmc5883
    HMC5883_SPI on SPI bus 1 at 5 (11000 KHz)
    Have SPI hmc5883
    MPU6000 on SPI bus 1 at 6 (1000 KHz)
    Found ICM-20608 internal
    MPU9250 on SPI bus 1 at 4 (1000 KHz)
    Found mpu9250 internal

    I cant reliably test previous versions, because those having startup issues. So this is at least something being worked on.

    BTW PX4 flight stack current master initializes all my sensors properly, no test fails. Cant just update px4-firmware module, because there seems to be api changes. So my hope is, once the current PX4Firmware gets integrated, my clone may start working.

    BTW2 :) AUAV PixRacer is on its way, thanks @Philip!

  • I see that the pixracer uses an ICM20608 IMU. AP_InertialSensor_PX4.cpp only handles initializing MPU6000, MPU9250, and LG3D20.

    How is the inertial sensor properly initialized on this board?

  • I emailed on 13th, replying to a mail I got. So only my last mail wasnt aswered (1 of 3), until now ;).

    This is not an issue for me, just the reason why posted here my question. So i would not blame anyone, nor im angry, im just excited. Probably wasting my time on the faulty clone is reducing my patience level, but thats my fault.

    Phillip Kocmoud said:

    Nick has your order marked as Ready to Ship. This means it is on the way to the post office.

    When did you email us? We reply to every email that we receive, good or bad...

  • Nick has your order marked as Ready to Ship. This means it is on the way to the post office.

    When did you email us? We reply to every email that we receive, good or bad...

This reply was deleted.