PixRacer with Ardupilot

This is a discussion to focus the feedback and support of ardupilot on the PixRacer board from

We believe that all teething problems encountered are now resolved and so we recommend people load Copter-3.3.4 which is available for all multicopters through the Mission Planner's (and other GCS's) Install Firmware screens.  Note that because regular Pixhawks are still on Copter-3.3.3 the install icon may show Copter-3.3.3 but rest assured, Copter-3.3.4 will be installed (you can check the version by looking at the very top of the Mission Planner).


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • +1  Same set up, worked with no problems.  Wifi looks to be a ways off on the APM stack.

      cheers ,  

       off topic but i'm ready to pay my share for development when the button is enabled.

  • Philip: any news about stock?

    • I am in Chicago.

      • Nice, thank's.

    • Hi Cala - we are still filling back orders. I expect more stock next week.

      • Thank's Philip :) ; were are you located?

    • Philippppp!!!!!

  • S-bus in APM and PX4 seems to be fixed for me including dev 3.4... works fine now.

    wifi and blue tooth work with PX4 but not in any of the APM copter versions I've tried. 3.3.3  3.3.4  3.4 

    Has anybody gotten wifi or BT working with APM copter? or 3dr radio for that matter?? 

  • I am getting 
    GPS : No GPS
    Status:  gpstatus = 0

    GPS_TYPE = 1 (Auto)
    GPS_TYPE2 = 0 (None)

    I am outdoors on screen porch but it should not say gpsstatus=0 if not attached

    GPS lights are Blue and Red are blinking

    I am also getting
    Error Compass Variance from time to time

    • Your gps have compass?

This reply was deleted.