Plane 3.6, rtl failsafe came on while testing on ground, big oscillations

As I wrote in title, just doing some setting up on ground.
Somehow when I had turned on pixhawk it initiated with RTL mode on, I hadn't notice tbh because I'd been having issues arming the pixhawk.
After recalibrating and turning off 2nd compass, then taking outside to get GPS lock, I was surprised when this time it worked and did throttle arm.

However the rudder and elevator badly oscillated, I am assuming this has something to do with it being in rtl mode and becoming confused?
I am concerned because it is primarily the RTL function that I want, and if it oscillated like that in the air it would surely crash.

Did this issue likely only happen as a result of being on ground, how can I test with reduced risk?

One concern I have is that if rtl isn't setup correctly and a failsafe is initiated the model might fly away!?

I guess presumably I should turn off failsafes before testing rtl with a switch? Or what is the recommended way?


Oh I am using pixhawk , frsky x9d , bix3

PIDs and other control values I got from advice on youTube from someone using a Bix3, I was hoping they be a good starting point at least.

Views: 188

Reply to This

Replies to This Discussion

No info?

I am trying to find out what is normal behaviour for RTL when on ground and throttle armed, my plane perhaps thought it was in the air , the servos were oscillating. I can't be the only one wanting to know what to expect when testing on the ground.
Thanks for any comments.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service