Hi all,

While I was testing APM 2.0 with my ESC which provides 5V power, I think I accidentally short the 5V and GND on sensor rail. The result is that:

1. APM 2 immediately power off, no burnt smell and no visible burnt trace or parts.

2. Board won't get power through 5V from output rail through ESC anymore

3. Vcc (+ on input and sensor rail) is separated by only 33ohm from GND (which multimeter read as short)

4. When plugged into USB, LED indicators light up but no uart connection


I presume that I must have burnt some parts on board which short Vcc and GND. But I can't seem to find which one. I even removed GPS daughter board but still no visible burn.

Does anyone have an idea about what happened and how might I fix it?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you guys ever find a solution?  I had the voltage sensing resisters soldered with a cable for the balancing port, but I accidentally connected it backwards one day and poof....no more power through the IN or OUT channels.  The unit still works via USB- all the sensors, firmware, telemetry, etc.  What I have noticed is that if I plug the battery AND the balance port in, it does power the unit without USB and does power the receiver...so 100% working right?  Nope....there's no connection between the IN's and the APM- the hardwired 1-4 (5?) OUT ports do move servos on those channels (although not really correctly), but the software doesn't recognize that a transmitter is connected.  In theory this should help me narrow down the broken component, but alas....it doesn't.  I'm planning to buy another APM, but I'd love to find a way to fix this one for future use....

  • Same issue here.

    I can get power from the USB, as well as the input rail, but when powered from the output rail. The green light glows faint. None of the diodes or anything looks burned and I have never seen smoke or shorted out the APM.

    Zero flights. I had just finished calibrating my ESCs and was connecting my RC input which is a 5 pin connector to the signal and one cable. Pretty hard to screw that up. Outer pin is the ground on almost every flight controller.

    Their response along with the basic troubleshooting stuff which had already been done...:

    If you are able to use the APM fine via USB, can you run the CLI tests to check the hardware? 

    We cannot offer to receive the APM2.0 for free repairs or a replacement as our warranty only covers boards that are defective from the factory. (terms of use:https://store.diydrones.com/Terms.asp); however, we will be happy to help you troubleshoot the problem and maybe suggest a work-around depending on the condition of the hardware. "


    So no service options even? I ran the CLI tests and everything responds fine. Support however is not getting back to me after 2 days of replying with my order number and further tests. I even offered to show video or pictures to help with diagnosis...


    I hope it gets worked out otherwise I never even got a chance to get this board off the ground.

    I've got a Naze32, Paris Multiwii, Quadrino, Naza GPS, OPCC, CC3d, Crius SE, Miniwii and have flown them all on various platforms. This isn't exactly my first rodeo. I just hope support can offer me a workaround. Tapping into 5v esc power to the output rail currently on my Hexa build and the board won't power up.

    My first APM1 experience wasn't all that great. I hope I can get this thing off the ground. I even bought 3dr's radio set, and sonar...

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21