Hi All, 

I have just upgraded to mission planner 1.3.6 build 1.1.5306.14681 and I can not get the compass calibration to work. I am building a new copter and this is a show stopper for me since you can't arm without compass calibration (quite sensibly! )

I just tried on my old copter which used to calibrate fine and its not possible there too ... can you help?

Please see attached screenshot for error details.

PC is running Windows 8.1




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have a similar problem when I try to calibrate my GPS. I´m using an APM 2.8 and the latest version of MP. When I try to calibrate my GPS after some movements, I get an error and I can't calibrate it. 2 months ago I could calibrate it but I change the MP version and then I get this error. I tried to use the same version of MP but it doesn't work.

    Could someone help me? I'm stuck


  • Resolved in Mission Planner 1.3.7!



    • Andy - Where did you find 1.3.7?

      • Hey Quadz' ... and all the others which operations were delayed by this minor ... Bug.

        Like Richard said, I just got it from the « Help » menu then, at the bottom of the screen, select « Upgrade » and ... Voila!  You've just upgraded to 1.3.7, built 1.1.5307.24027.

        Thanks to Christ Anderson and all those who participated in finding a cure to this « epidemic ».  Without them, we might have never found the « vaccine »!

        Best regards,


        • Richard - Thanks for your help finding MP 1.3.7.

          Daniel - Glad to hear that 1.3.7 solved your problem.  What firmware version are you running?  I have had no luck at all with AC 3.2rc2

          I am still walking in circles.

          Here is the result with 1.3.7 build 1.1.5307.24027 (the version that updates when you click 'Check for Updates' on the help page)


          Here is the result with 1.3.6 build 1.1.5307.23371 (The version that updates when you click 'Check for Beta Updates' on the help page)


          • Hi Quadz!  Sorry for the delay!  I was a little tied up ...in my USB extension cord ... while performing the « Calibration Dance »! ;-)

            I am a bit green in this business, so allow me to ask you how to get the version of that Firmware, and I'll be more than glad to share this information with you.

            Looking at your dot pattern, you seem to be missing a whole area on that full X-Y-Z three dimensional representation.  It leads me to think you might have some magnetic interference.

            Allow me to share with you a weird thing that happened to me today.  I'm using one of those « Airbot » GPS / Compass combination, since I'm using the 2.6 version of the APM Flight Controller.

            I didn't like the way the sides were (too angled) and took too much space on my HJ-H4 Airframe, so I decided to make a smaller shield, using coper plates that I soldered to each sides of the unit, making it much smaller and more adequate for mounding on that Airframe type.  Looks better too!!

            This afternoon, I wanted to maximize the shielding, closing that box completely.  Ran to the local hobby shop to get me some longer M3 screws, and boom!  Super good job.  Re-calibrated the whole thing to make sure all was still okay!  ... NOT !!

            Making a coper Faraday cage that enclosed a compass is NOT a good idea!  Weird things happens when you deny magnetic fields to a compass!  Hehehe!  I experimented on that a few months back, and I'll let you know the links to my YouTube channel to show you what can happen when those two come in contact.  You will be amaze!  Just give me time to get those videos up there and I'll get back at you with the info.  So I reopened the cage and Voila!  Perfect operation again.

            Anyway!  Again, Quadz, let me know how to get this info and, like I said, I'll be more than glad to share this info with you, and we will share experiences.  Personally, I'm stuck at step 12 of 16, for I can't seem to be able to arm my ESCs.  I'm using a « Quattro 30x4 » Four-in-One from « Favorite » and I think I have to calibrate the ESC in some way... I'm not sure.  I'll ask around, and maybe someone was this ESC type and just might help me on this.

            So ... it's late and I'm tired!  I think I'll go rest now.

            Have a great week, and I wish you luck with your Quads.  I sure want to help if I can.

            Good night!

            Yours truly,


            • Hello,

              My english is not so perfect. I'm very sorry about that..but i'm trying it..;)

              @Quadzimodo: could you solve this problem? My Copter has the same problem...and i didn't know what to do....:(

              It works fine...a few months ago...I#ve done nothing with that. After rebuilding my copter i've tried to calibrate the external 3DR-Module on my APM 2.5 and 2.6...the same problem.

              Could someone help me?

              I've no magnetic fields or something else....:(

              • Matthias - Had not touched my APM equipped quad in 10 weeks. When I saw your message I had a go at troubleshooting again with fresh MP install, restored default settings, updated firmware, repositioned mag (increased distance from frame by factor of 4)... But I have had no success. I have tried everything I can think of but cannot seem to get a health calibration. Very frustrating.
                • Update - Found the source of all my frustration... Fatigued multimeter leads... Leading to incorrect diagnosis of cut trace on new FC board (continuity test across solder pads indicated onboard compass was disabled when it wasn't). As a result, all my calibrations were being attempted with two compasses in parallel. No wonder it was failing regardless of where I put the external compass, which external compass I used, or how I configured it.
                  My favourite bird is back running like a well oiled rifle once again.
          • Yep the 3.1.7 build works. I got my compass calibration done and will get a test flight in later in the day hopefully. Thanks for the quick response to the issue. 

This reply was deleted.