Possible fault with APM 2.0


Hopefully you can help me diagnose what I believe to be a failed ATMEGA32U2 chip on my APM 2.0 based on the following diagnosis.

  1. PC no longer makes a beep when connected via USB and extra COM port is not found.
  2. RX and TX leds no longer flash on the board
  3. Receiver inputs no longer control the servo's (PPM encoder not working ? i.e. 32U2 chip)
  4. Attempting to update the 32U2 firmware (thought it may have become corrupt) fails. PC still doesn’t see APM 2.0 following reset of 32U2 and hence unable to flash.
This was the procedure I followed to try and see if I could reflash the 32U2.

The rest of the board seems to be fine as the blue/red/yellow LEDs flash as normal and the servos centre after about 5 seconds following switch on.

Anybody any ideas on what else I can check or do you agree that the 32U2 chip is dead ?

Many thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • We had a similar problem. Completely unable to load firmware "error cannot detect APM version". Initially we thought it was a bootloaders problem
    It turned out that a component (cannot remember which) had fallen off in shipping
  • Moderator

    I have found on my board the same symptoms and have put it down to loose connection of the mini usb cable, as sometimes it works and sometimes it doesnt, it requires moving around slightly until it connects and then dont even look at it or it disconnects again. The board is new and never crashed and I have tried a different usb cable and have the same problem.

  • I had a light crash yesterday, (no props broken and no physical damage to the APM2) and mine has the exact same symptoms.

This reply was deleted.


Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3