Possible to disable internal compass?

We have some onboard electronics which switch on/off during flight. We know when these systems are activated they cause MAJOR issues with magnetic interference with the onboard (Pixhawk) compass. It is enough to cause a flyaway/crash when in an autonomous/loiter mode. The external compass is far enough away that it is almost entirely immune to this.

Is it possible to disable the internal pixhawk compass?  Basically we would never want to fly unless the external one was operational and if the system fell back to the internal compass it would certainly cause a crash.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Not sure if I did the right thing, but in QGC I deleted the third compass ID. I'm getting a message that compass 2 not calibrated, but zero drifting and pointing the right direction too. Arming possible and all flight modes working. 

    Happy days :)

  • Very strange !

    I disable internal compass with the GUI under compass menu : uncheck compass 2. verifying in the full parameter list that compas use2 = 0. Reboot pixhawk, double check.

    Now I move gps 3dr lea 6h virtual horizon is not moving. I move the pixhawk, I have a reaction in virtual horizon. I don't understand how does it works ...

    • This is because the FC uses the accelerometer/gyro to determine heading change as well as using compass.

      The MAG field is subject to variation and if it moves slightly without the FC sensing movement it is ignored, the accelerometer/gyro movement must match the compass reading.

      You should notice that if you move the compass 90 deg without the FC moving that you get a Compass Variance warning message in the mission planner HUD.

      If you really want to be sure that you FC is using your external compass then boot it up with the compass and FC aligned together and move round until you are pointing north, so you you see it points north in mission planner.

      Make a note of what direction north is and disconnect the FC from mission planner and power down.

      After its powered down turn the compass so it is at 90 deg to the FC, now reboot the FC and connect to mission planner, you should now see that the north heading in mission planner corresponds to the compass and not the front of the FC .

      The proves that the FC has taken north from the external compass.

  • same here can't disable the internal compass....

    • Perhaps its not the latest beta update of missionplanner? The compass screen changed considerbly at some point in the last few months.

  • Should be able to disable in missionplanner (I'm using the latest beta, not sure if earlier version are similar) in the initial setup tab. Make compass 1 the external, then under compass 2, disable (or uncheck "use this compass" or something similar- going from memory here). I think what gets a lot of people is that compass1 is the external, and 2 is the internal.

    • Unfortunately no sense at all :-(

      Copter v.3.3.3

      MP 1.3.37.3

      Any other ideas?

  • I'm having this issue too with 3.3.3-rc2. I cannot get the internal compass to disable no matter how I adjust the settings. :(

    • Other way: in full params list, compass use 2 =0  (going for memory too but if you don't find I check it), Derek comment is the new way In latest MP, update it to find.

  • The internal compass on my PX4 is really screwing up my copter. I know... the external compass is supposed to take priority, but something ain't right. I just want to disable the internal compass in my PX4, but that doesn't seem possible. The internal compass won't hold a steady heading no matter what. I can leave my copter sitting on the floor of my living room for 15 minutes, and in that time the internal compass will make a complete 360. 

    I plug in the external Ublox GPS with compass and I just get compass errors. I can take the same Ublox GPS/compass, plug it into my APM 2.6 and it works fine. But when I plug the Ublox into my PX4, Mission Planner never shows the copter pointing in the right direction. I do a compass calibration and it gives me offsets of +500 (which is supposedly not possible). 

    Basically, the internal compass is AFU. It's messing everything up.  All I want to do is disable the damn thing, but that doesn't seem to be possible. 

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…