Greetings

Recently I have been facing a very weird issue with my drone. Voltage sensing is completely off. As soon as I takeoff my battery voltage drops to values like 6V from 16V (verified from logs). I have calibrated my voltage and current sensors from the battery monitor calibration settings in mission planner :: initial setup>optional hardware>battery monitor. But still when voltage drops there’s a significant difference compared to actual voltage (from cell meter). Hence I am not able to use the battery failsafe voltage. As soon as drone takes off failsafe is activated. Tried changing the power module. Still problem persists. Checked battery life by connecting an independent cell meter. Battery is ok. Any idea how to fix or why this is happening?

My setup:
f450 Quad
850 kV motor
40A Esc
10" props
Pixhawk Cube 2.1 Running arducopter 3.6.9
Brick Power Module which came inbox with Cube

Edit: The other power module i tried was from Radio Link

Views: 34

Reply to This

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service